aboutsummaryrefslogtreecommitdiffstats
path: root/print/p5-Net-CUPS
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-09-13 16:37:57 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-09-13 16:37:57 +0800
commit6aeac0ae274bc8d30833d18f402aff86202ff8ef (patch)
treed701ace1655c4f2254a4449b1688adf24b9e9b0d /print/p5-Net-CUPS
parent12a60f605b6cef6f674019450c7eb055e47b18f8 (diff)
downloadfreebsd-ports-gnome-6aeac0ae274bc8d30833d18f402aff86202ff8ef.tar.gz
freebsd-ports-gnome-6aeac0ae274bc8d30833d18f402aff86202ff8ef.tar.zst
freebsd-ports-gnome-6aeac0ae274bc8d30833d18f402aff86202ff8ef.zip
- Add p5-Net-CUPS 0.61
Previous versions of this module attempted to provide a Perl interface layer similar to the C interface of CUPS. This was fine for power users, but most people were not looking for this type of interface. This module has now been converted to use an object oriented paradigm to facilitate quicker development and ease of use. WWW: http://search.cpan.org/dist/Net-CUPS/ PR: ports/160644 Submitted by: Veniamin Gvozdikov <g.veniamin@googlemail.com>
Diffstat (limited to 'print/p5-Net-CUPS')
-rw-r--r--print/p5-Net-CUPS/Makefile27
-rw-r--r--print/p5-Net-CUPS/distinfo2
-rw-r--r--print/p5-Net-CUPS/pkg-descr8
-rw-r--r--print/p5-Net-CUPS/pkg-plist18
4 files changed, 55 insertions, 0 deletions
diff --git a/print/p5-Net-CUPS/Makefile b/print/p5-Net-CUPS/Makefile
new file mode 100644
index 000000000000..4568a0d69234
--- /dev/null
+++ b/print/p5-Net-CUPS/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Net-CUPS
+# Date created: 2011-09-11
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-CUPS
+PORTVERSION= 0.61
+CATEGORIES= print perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Interface to the CUPS API
+
+BUILD_DEPENDS= cups-config:${PORTSDIR}/print/cups-client
+LIB_DEPENDS= cupsimage.2:${PORTSDIR}/print/cups-image
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::CUPS.3 \
+ Net::CUPS::Destination.3 \
+ Net::CUPS::IPP.3 \
+ Net::CUPS::PPD.3
+
+.include <bsd.port.mk>
diff --git a/print/p5-Net-CUPS/distinfo b/print/p5-Net-CUPS/distinfo
new file mode 100644
index 000000000000..21a8a15667ca
--- /dev/null
+++ b/print/p5-Net-CUPS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-CUPS-0.61.tar.gz) = fd4a5a86038df9dfe57dcfed78b2d045e4b18d507a6fa5a8f82ecb3a732e0e35
+SIZE (Net-CUPS-0.61.tar.gz) = 83893
diff --git a/print/p5-Net-CUPS/pkg-descr b/print/p5-Net-CUPS/pkg-descr
new file mode 100644
index 000000000000..6a2bbea0aebf
--- /dev/null
+++ b/print/p5-Net-CUPS/pkg-descr
@@ -0,0 +1,8 @@
+Previous versions of this module attempted to provide a Perl interface
+layer similar to the C interface of CUPS. This was fine for power users,
+but most people were not looking for this type of interface.
+
+This module has now been converted to use an object oriented paradigm
+to facilitate quicker development and ease of use.
+
+WWW: http://search.cpan.org/dist/Net-CUPS/
diff --git a/print/p5-Net-CUPS/pkg-plist b/print/p5-Net-CUPS/pkg-plist
new file mode 100644
index 000000000000..2ef8dc0cdebf
--- /dev/null
+++ b/print/p5-Net-CUPS/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/CUPS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/CUPS/Destination.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/CUPS/IPP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/CUPS/PPD.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CUPS/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CUPS/CUPS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CUPS/CUPS.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CUPS/Destination/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CUPS/IPP/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CUPS/PPD/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CUPS/autosplit.ix
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CUPS/PPD
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CUPS/IPP
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CUPS/Destination
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/CUPS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/CUPS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Net