aboutsummaryrefslogtreecommitdiffstats
path: root/print/panda
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-08-26 12:22:20 +0800
committermiwi <miwi@FreeBSD.org>2011-08-26 12:22:20 +0800
commit325a63d0bf9163c96d08b7e6f08c7568d680e363 (patch)
treede5c2adf7efd245f1606da5660d76b003b8d99a9 /print/panda
parent6e00622b0aae418975bc061eb59b949cdf25e007 (diff)
downloadfreebsd-ports-gnome-325a63d0bf9163c96d08b7e6f08c7568d680e363.tar.gz
freebsd-ports-gnome-325a63d0bf9163c96d08b7e6f08c7568d680e363.tar.zst
freebsd-ports-gnome-325a63d0bf9163c96d08b7e6f08c7568d680e363.zip
- Fix MASTER_SITES
- Add LICENSE - Support NOPORTEXAMPLES PR: 160139 Submitted by: Ports Fury
Diffstat (limited to 'print/panda')
-rw-r--r--print/panda/Makefile10
-rw-r--r--print/panda/pkg-plist34
2 files changed, 25 insertions, 19 deletions
diff --git a/print/panda/Makefile b/print/panda/Makefile
index 39aeea737f1d..ee0a1a0c1a8c 100644
--- a/print/panda/Makefile
+++ b/print/panda/Makefile
@@ -10,12 +10,15 @@ PORTVERSION= 0.5.4
PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= SF \
- ${MASTER_SITE_SAVANNAH} \
+ SAVANNAH \
http://www.stillhq.com/panda/source/
MAINTAINER= ports@FreeBSD.org
COMMENT= A PDF generation library
+LICENSE= GPLv2 LGPL21
+LICENSE_COMB= dual
+
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
@@ -25,9 +28,10 @@ USE_GNOME= gnomehack pkgconfig
USE_BDB= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-berkeley-db
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
CPPFLAGS= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${BDB_LIB_DIR} -L${LOCALBASE}/lib ${PTHREAD_LIBS}
@@ -50,6 +54,8 @@ post-install:
.for f in AUTHORS CONTRIBUTORS ChangeLog DEV-HINTS README TODO UNDERWAY
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
.for f in IMAGES examples/*.c examples/c++/*.cpp examples/images/*.*
${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}
diff --git a/print/panda/pkg-plist b/print/panda/pkg-plist
index 32d1d42ba7d3..4cf73b98e913 100644
--- a/print/panda/pkg-plist
+++ b/print/panda/pkg-plist
@@ -14,22 +14,22 @@ libdata/pkgconfig/panda.pc
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/UNDERWAY
-%%PORTDOCS%%%%EXAMPLESDIR%%/IMAGES
-%%PORTDOCS%%%%EXAMPLESDIR%%/RedbrushAlpha.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/circles.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/empty.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/exercise.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/gnu-head.jpg
-%%PORTDOCS%%%%EXAMPLESDIR%%/gnu.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/gnu_box.jpg
-%%PORTDOCS%%%%EXAMPLESDIR%%/input.tif
-%%PORTDOCS%%%%EXAMPLESDIR%%/input2.tif
-%%PORTDOCS%%%%EXAMPLESDIR%%/legacymain.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/libpng.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/main.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/morecircles.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/pandaexample.cpp
-%%PORTDOCS%%%%EXAMPLESDIR%%/template.c
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/IMAGES
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/RedbrushAlpha.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/circles.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/empty.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exercise.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gnu-head.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gnu.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gnu_box.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/input.tif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/input2.tif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/legacymain.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libpng.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/main.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/morecircles.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pandaexample.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/template.c
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/panda