aboutsummaryrefslogtreecommitdiffstats
path: root/print/passivetex
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-23 16:44:08 +0800
committerkrion <krion@FreeBSD.org>2004-03-23 16:44:08 +0800
commit6dfbbfa09913399f60009ad59b860d6879632996 (patch)
tree71e3d59eabebac98a127e1ae30de7ca663ad66a7 /print/passivetex
parent54f2b675141bb24706880e0910a9fad86a2b87b4 (diff)
downloadfreebsd-ports-gnome-6dfbbfa09913399f60009ad59b860d6879632996.tar.gz
freebsd-ports-gnome-6dfbbfa09913399f60009ad59b860d6879632996.tar.zst
freebsd-ports-gnome-6dfbbfa09913399f60009ad59b860d6879632996.zip
- Fix WWW:
- Fix dependencies - Some style changes PR: ports/64527 Submitted by: maintainer
Diffstat (limited to 'print/passivetex')
-rw-r--r--print/passivetex/Makefile86
-rw-r--r--print/passivetex/pkg-descr2
2 files changed, 40 insertions, 48 deletions
diff --git a/print/passivetex/Makefile b/print/passivetex/Makefile
index b7a3a3aefea2..974351217c17 100644
--- a/print/passivetex/Makefile
+++ b/print/passivetex/Makefile
@@ -5,62 +5,58 @@
# $FreeBSD$
#
-PORTNAME= passivetex
-PORTVERSION= 1.24
-CATEGORIES= print
-MASTER_SITES= http://www.tei-c.org.uk/Software/passivetex/
-DISTNAME= ${PORTNAME}
-DIST_SUBDIR= ${PORTNAME}
+PORTNAME= passivetex
+PORTVERSION= 1.24
+PORTREVISION= 1
+CATEGORIES= print
+MASTER_SITES= http://www.tei-c.org.uk/Software/passivetex/
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PORTNAME}
-MAINTAINER= hrs@FreeBSD.org
-COMMENT= XSL FO processor, written in TeX
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= XSL FO processor, written in TeX
-BUILD_DEPENDS= kpsewhich:${PORTSDIR}/print/teTeX \
- ${LOCALBASE}/share/texmf/web2c/xmltex.fmt:${PORTSDIR}/print/xmltex
+BUILD_DEPENDS= ${LOCALBASE}/share/texmf/web2c/xmltex.fmt:${PORTSDIR}/print/xmltex \
+ ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+RUN_DEPENDS= ${BUILD_DEPENDS}
-NO_BUILD= yes
-USE_ZIP= yes
-WRKSRC= ${WRKDIR}/passivetex
-MAKE_ENV= TEXMFCNF=${FILESDIR}:${LOCALBASE}/share/texmf/web2c
+NO_BUILD= yes
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/passivetex
+MAKE_ENV= TEXMFCNF=${FILESDIR}:${LOCALBASE}/share/texmf/web2c
-MESSAGE= ${PKGDIR}/pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
+MESSAGE= ${PKGDIR}/pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
PLIST_SUB= MKTEXLSR=${MKTEXLSR} CLASSDIR=${CLASSDIR}
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
-.if exists(${LOCALBASE}/bin/kpsewhich)
-TEXMFDIR!= ${LOCALBASE}/bin/kpsewhich -expand-var '$$TEXMFMAIN'
-.else
-TEXMFDIR= # empty
-.endif
-CLASSDIR= ${TEXMFDIR:S,^${PREFIX},,:S,^/,,}/tex/passivetex
-CLASS_FILES= dummyels.sty fotex.xmt fotex.sty
-CLASS_FILES+= mlnames.sty ucharacters.sty unicode.sty
-CLASS_FILES+= dummyels.sty nomulticol.sty
+CLASSDIR= ${TEXMFLOCAL}/tex/passivetex
+CLASS_FILES= dummyels.sty fotex.xmt fotex.sty \
+ mlnames.sty ucharacters.sty unicode.sty \
+ dummyels.sty nomulticol.sty
DOC_FILES= LICENSE README.passivetex index.html index.xml
-TEST_FILES= Makefile
-TEST_FILES+= chap01.xml chap02.xml chap03.xml chap04.xml
-TEST_FILES+= check.xsl
-TEST_FILES+= darkness.fo darkness.pdf darkness.xml darkness.xsl
-TEST_FILES+= exercise-print.xsl exercise.fo exercise.pdf exercise.xml
-TEST_FILES+= fezziPic.png fotex.cfg.eg hyperref.cfg
-TEST_FILES+= mathex.xml mathex.xsl mathml.xsl
-TEST_FILES+= mathtei.dtd novel.dtd
-TEST_FILES+= phys332-1.jpg phys332-2.jpg
-TEST_FILES+= rmsd.xml
-TEST_FILES+= tei-oucs.dtd tei.sty teimath-print.xsl teimath.aux teimath.fo
-TEST_FILES+= teimath.log teimath.out teimath.pdf teimath.xml teimath.xsl
-TEST_FILES+= teimath2.xml teiu5-print.xsl teiu5.fo teiu5.pdf teiu5.xml
-TEST_FILES+= teixlite.dtd teixml.cfg test1.fot test2.fot
+TESTDIR= ${DOCSDIR}/test
+TEST_FILES= Makefile chap01.xml chap02.xml chap03.xml chap04.xml \
+ check.xsl darkness.fo darkness.pdf darkness.xml darkness.xsl \
+ exercise-print.xsl exercise.fo exercise.pdf exercise.xml \
+ fezziPic.png fotex.cfg.eg hyperref.cfg \
+ mathex.xml mathex.xsl mathml.xsl mathtei.dtd novel.dtd \
+ phys332-1.jpg phys332-2.jpg rmsd.xml \
+ tei-oucs.dtd tei.sty teimath-print.xsl teimath.aux teimath.fo \
+ teimath.log teimath.out teimath.pdf teimath.xml teimath.xsl \
+ teimath2.xml teiu5-print.xsl teiu5.fo teiu5.pdf teiu5.xml \
+ teixlite.dtd teixml.cfg test1.fot test2.fot
post-patch:
- @${SED} -e 's,%%TEXMFDIR%%,${TEXMFDIR},' \
+ @${SED} -e 's,%%TEXMFDIR%%,${LOCALBASE}/share/texmf,' \
${MESSAGE} > ${PKGMESSAGE}
do-install:
@@ -69,16 +65,12 @@ do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
- ${MKDIR} ${DOCSDIR}/test
- ${INSTALL_DATA} ${TEST_FILES:S@^@${WRKSRC}/test/@} ${DOCSDIR}/test
+ ${MKDIR} ${TESTDIR}
+ ${INSTALL_DATA} ${TEST_FILES:S@^@${WRKSRC}/test/@} ${TESTDIR}
.endif
-post-install: rebuild-tex-database display-message
-
-rebuild-tex-database:
+post-install:
${MKTEXLSR}
-
-display-message:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/print/passivetex/pkg-descr b/print/passivetex/pkg-descr
index 7947778672f9..8062396e3f67 100644
--- a/print/passivetex/pkg-descr
+++ b/print/passivetex/pkg-descr
@@ -7,4 +7,4 @@ For example, to generate a PDF file from an FO file, run
pdftex --interaction nonstopmode "&pdfxmltex" file.fo
-WWW: http://www.hcu.ox.ac.uk/TEI/Software/passivetex/
+WWW: http://www.tei-c.org.uk/Software/passivetex/