aboutsummaryrefslogtreecommitdiffstats
path: root/print/pdftk
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-04-02 09:47:27 +0800
committerpav <pav@FreeBSD.org>2004-04-02 09:47:27 +0800
commit0f74e9d5dc78633dbb3047be7920256b28911e73 (patch)
treebeff5abf882a5c531a0a094526cd6aba13c28e9d /print/pdftk
parentc415669b2252646546300ba6e98e1c3a25e53910 (diff)
downloadfreebsd-ports-gnome-0f74e9d5dc78633dbb3047be7920256b28911e73.tar.gz
freebsd-ports-gnome-0f74e9d5dc78633dbb3047be7920256b28911e73.tar.zst
freebsd-ports-gnome-0f74e9d5dc78633dbb3047be7920256b28911e73.zip
Add pdftk, a simple tool for doing everyday things with PDF documents.
Keep one in the top drawer of your desktop and use it to: Merge PDF Documents Split PDF Pages into a New Document Decrypt Input as Necessary (Password Required) Encrypt Output as Desired Burst a PDF Document into Single Pages Report on PDF Metrics, including Metadata and Bookmarks Uncompress and Re-Compress Page Streams Repair Corrupted PDF (Where Possible) PR: ports/64555 Submitted by: Patrick Dung <patrick_dkt@yahoo.com.hk>
Diffstat (limited to 'print/pdftk')
-rw-r--r--print/pdftk/Makefile41
-rw-r--r--print/pdftk/distinfo2
-rw-r--r--print/pdftk/pkg-descr19
3 files changed, 62 insertions, 0 deletions
diff --git a/print/pdftk/Makefile b/print/pdftk/Makefile
new file mode 100644
index 000000000000..6d9c98fb4588
--- /dev/null
+++ b/print/pdftk/Makefile
@@ -0,0 +1,41 @@
+# Ports collection makefile for: pdftk
+# Date created: 18 March, 2004
+# Whom: Patrick Dung (patrick_dkt@yahoo.com.hk)
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdftk
+PORTVERSION= 0.94
+CATEGORIES= print
+MASTER_SITES= http://www.accesspdf.com/pdftk/
+
+MAINTAINER= patrick_dkt@yahoo.com.hk
+COMMENT= A simple tool for doing everyday things with PDF documents
+
+# needs gcj
+BUILD_DEPENDS= gcj33:${PORTSDIR}/lang/gcc33
+
+USE_GCC= 3.3
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}
+
+MAKEFILE= Makefile.Generic
+MAKE_ENV= CXX=g++33 GCJ=gcj33 GCJH=gcjh33
+
+MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/pdftk
+
+post-extract:
+ @${REINPLACE_CMD} -e "s|CC_OPTS \+\=|CC_OPTS \+\= ${PTHREAD_CFLAGS} ${PTHREAD_LIBS} -liconv -lz|g" ${WRKSRC}/Makefile.Base
+ @${REINPLACE_CMD} -e "s|g\+\+|g\+\+33|g" ${WRKSRC}/Makefile.Generic
+ @${REINPLACE_CMD} -e "s|MAKE)|MAKE) GXX=g++33 GCJ=gcj33 GCJH=gcjh33| " ${WRKSRC}/Makefile.Base
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/../debian/${PORTNAME}.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/print/pdftk/distinfo b/print/pdftk/distinfo
new file mode 100644
index 000000000000..74ee6327aca4
--- /dev/null
+++ b/print/pdftk/distinfo
@@ -0,0 +1,2 @@
+MD5 (pdftk-0.94.tar.gz) = 3b4d8c3d9e1f95d0194bc393465bd24a
+SIZE (pdftk-0.94.tar.gz) = 688728
diff --git a/print/pdftk/pkg-descr b/print/pdftk/pkg-descr
new file mode 100644
index 000000000000..7d3a01ec4b2e
--- /dev/null
+++ b/print/pdftk/pkg-descr
@@ -0,0 +1,19 @@
+If PDF is electronic paper, then pdftk is an electronic staple-remover,
+hole-punch, binder, secret-decoder-ring, and X-Ray-glasses.
+Pdftk is a simple tool for doing everyday things with PDF documents.
+Keep one in the top drawer of your desktop and use it to:
+
+Merge PDF Documents
+Split PDF Pages into a New Document
+Decrypt Input as Necessary (Password Required)
+Encrypt Output as Desired
+Burst a PDF Document into Single Pages
+Report on PDF Metrics, including Metadata and Bookmarks
+Uncompress and Re-Compress Page Streams
+Repair Corrupted PDF (Where Possible)
+
+Pdftk is also an example of how to use a library of Java classes
+in a stand-alone C++ program. Specifically, it demonstrates how GCJ and CNI
+allow C++ code to use iText's (itext-paulo) Java classes.
+
+WWW: http://www.accesspdf.com/pdftk/