aboutsummaryrefslogtreecommitdiffstats
path: root/print/pips800
diff options
context:
space:
mode:
authorru <ru@FreeBSD.org>2003-07-28 18:19:43 +0800
committerru <ru@FreeBSD.org>2003-07-28 18:19:43 +0800
commit88c44214b974478d87a125245b3b89dd573ecaa9 (patch)
tree0b418e2669680e78bc9eba1ea8976055fa6453aa /print/pips800
parentcd080fcb446edc81b7341a2d91aedeadcc818200 (diff)
downloadfreebsd-ports-gnome-88c44214b974478d87a125245b3b89dd573ecaa9.tar.gz
freebsd-ports-gnome-88c44214b974478d87a125245b3b89dd573ecaa9.tar.zst
freebsd-ports-gnome-88c44214b974478d87a125245b3b89dd573ecaa9.zip
Fixed broken string comparisons that were made apparent only after
the recent make/cond.c fix. Strictly speaking, all comparisons in this makefile should be the string-type, and as such, RHSes should be enclosed in double-quotes, as explained in section 4.3 of the PMake -- A Tutorial (PSD:12-39), but to make "make describe" happy in ports/print, this was enough, and the rest is now up to the respective maintainer. Urged by: kris
Diffstat (limited to 'print/pips800')
-rw-r--r--print/pips800/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/print/pips800/Makefile b/print/pips800/Makefile
index 34fcf6e98deb..5f524e9895d9 100644
--- a/print/pips800/Makefile
+++ b/print/pips800/Makefile
@@ -57,10 +57,10 @@ PRT_MODEL= ${PRTYPE:U:S/^-//}
.if ${PRTYPE} == 790
LIB_FILE= libpm${PRTYPE}pt.so
PRT_MODEL= PM${PRTYPE}PT
-.elif ${PRTYPE} == 780cs
+.elif ${PRTYPE} == "780cs"
LIB_FILE= libpm${PRTYPE}.so
PRT_MODEL= PM${PRTYPE:U}
-.elif ${PRTYPE} == 820ug
+.elif ${PRTYPE} == "820ug"
LIB_FILE= libpm820cug.so
PRT_MODEL= PM820CUG
.else
@@ -79,7 +79,7 @@ LANGS= ja
PLIST= ${MASTERDIR}/pkg-plist20
.elif ${PORTVERSION} == 1.3
PLIST= ${MASTERDIR}/pkg-plist13
-.elif ${PORTVERSION} == 1.3.1
+.elif ${PORTVERSION} == "1.3.1"
LANGS= de es fr it ja ko nl pt zh zh_TW
#RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/local/cmex16m.pcf.gz:${PORTSDIR}/chinese/cmexfonts
PLIST= ${MASTERDIR}/pkg-plist131
@@ -276,7 +276,7 @@ _MAKE_DESCR:
.else # for defined(INTERNATIONAL_PRODUCTS)
.if ${PRTYPE} != 800
.for file in pkg-descr
-.if ${PRTYPE} == 750_2000
+.if ${PRTYPE} == "750_2000"
${SED} -e 's/PM-800C/PM-750C PM-2000C/g' \
-e 's/pm800c/pm750c_2000c/g' \
-e 's/800/${PRTYPE}/g' \
@@ -286,12 +286,12 @@ _MAKE_DESCR:
-e 's/pm800c/pm790pt/g' \
-e 's/800/${PRTYPE}/g' \
${MASTERDIR}/${file} > ${.CURDIR}/${file}
-.elif ${PRTYPE} == 780cs
+.elif ${PRTYPE} == "780cs"
${SED} -e 's/PM-800C/PM-780CS/g' \
-e 's/pm800c/pm780cs/g' \
-e 's/800/${PRTYPE}/g' \
${MASTERDIR}/${file} > ${.CURDIR}/${file}
-.elif ${PRTYPE} == 820ug
+.elif ${PRTYPE} == "820ug"
${SED} -e 's/PM-800C/PM-820CUG/g' \
-e 's/pm800c/pm820cug/g' \
-e 's/800/${PRTYPE}/g' \