aboutsummaryrefslogtreecommitdiffstats
path: root/print/psmark
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-08-04 00:52:53 +0800
committerijliao <ijliao@FreeBSD.org>2002-08-04 00:52:53 +0800
commit763a3a872d682a3e28db7fa45e8704ee02280284 (patch)
treed1a29c3403fc483ae2fc163360a0f147a11a186d /print/psmark
parent06e39b8b426b3366f64b395e70bdace1898e7354 (diff)
downloadfreebsd-ports-gnome-763a3a872d682a3e28db7fa45e8704ee02280284.tar.gz
freebsd-ports-gnome-763a3a872d682a3e28db7fa45e8704ee02280284.tar.zst
freebsd-ports-gnome-763a3a872d682a3e28db7fa45e8704ee02280284.zip
add psmark 2.0
Renders a vertical string on any PostScript document
Diffstat (limited to 'print/psmark')
-rw-r--r--print/psmark/Makefile29
-rw-r--r--print/psmark/distinfo1
-rw-r--r--print/psmark/pkg-comment1
-rw-r--r--print/psmark/pkg-descr10
-rw-r--r--print/psmark/pkg-plist1
5 files changed, 42 insertions, 0 deletions
diff --git a/print/psmark/Makefile b/print/psmark/Makefile
new file mode 100644
index 000000000000..2037c1a137e5
--- /dev/null
+++ b/print/psmark/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: psmark
+# Date created: Aug 4, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= psmark
+PORTVERSION= 2.0
+CATEGORIES= print
+MASTER_SITES= http://www.antitachyon.com/obj/2/14/2/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
+
+MAN1= psmark.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CFLAGS|#CFLAGS|g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/psmark ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/psmark.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/print/psmark/distinfo b/print/psmark/distinfo
new file mode 100644
index 000000000000..53728a9617ae
--- /dev/null
+++ b/print/psmark/distinfo
@@ -0,0 +1 @@
+MD5 (psmark-v2.0.tar.gz) = 570ce1c7df24d1107c2e271f5887a023
diff --git a/print/psmark/pkg-comment b/print/psmark/pkg-comment
new file mode 100644
index 000000000000..bb8a0d084308
--- /dev/null
+++ b/print/psmark/pkg-comment
@@ -0,0 +1 @@
+Renders a vertical string on any PostScript document
diff --git a/print/psmark/pkg-descr b/print/psmark/pkg-descr
new file mode 100644
index 000000000000..a4613c55c901
--- /dev/null
+++ b/print/psmark/pkg-descr
@@ -0,0 +1,10 @@
+psmark is a C program that renders a vertical string on any PostScript
+document.
+
+Features :
+ - Prints "watermark"-like text on any PostScript document.
+ - Free choice of brightness, location, size, font, color, string to render
+ and angle.
+ - GPL program.
+
+WWW: http://www.antitachyon.com/?2,14,2
diff --git a/print/psmark/pkg-plist b/print/psmark/pkg-plist
new file mode 100644
index 000000000000..94e8ab180c7d
--- /dev/null
+++ b/print/psmark/pkg-plist
@@ -0,0 +1 @@
+bin/psmark