aboutsummaryrefslogtreecommitdiffstats
path: root/print/py-preppy
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-05-25 15:32:07 +0800
committermiwi <miwi@FreeBSD.org>2014-05-25 15:32:07 +0800
commit51c125d65242d4d33380ed1ad5f24d50772b8fcd (patch)
tree2f6d2227a65277ba13ee27e196cb9099662eae26 /print/py-preppy
parent1a4c9a2260257b3f6dd482e43c0924b69dc131cb (diff)
downloadfreebsd-ports-gnome-51c125d65242d4d33380ed1ad5f24d50772b8fcd.tar.gz
freebsd-ports-gnome-51c125d65242d4d33380ed1ad5f24d50772b8fcd.tar.zst
freebsd-ports-gnome-51c125d65242d4d33380ed1ad5f24d50772b8fcd.zip
Preppy is ReportLab's templating system. It was developed in late 2000 and has
been in continual production use since then. It is open source (BSD-license). The key features are: - *small*. Preppy is a single Python module. If you want a templating system 'in the box', it's easy to include it in your project - *easy to learn*. It takes about one minute to scan all the features - *just Python*. We have not invented another language, and if you want to do something - includes, quoting, filters - you just use Python - *compiled to bytecode*: a .prep file gets compiled to a Python function in a .pyc file - *easy to debug*: preppy generates proper Python exceptions, with the correct line numbers for the .prep file. You can follow tracebacks from Python script to Preppy template and back, through multiple includes - *easy to type and read*. We've been using ``{{this}}`` syntax since well before Django was thought of - *8-bit safe*: it makes no assumption that you are generating markup and does nothing unexpected with whitespace; you could use it to generate images or binary files if you wanted to. WWW: http://preppy.readthedocs.org/en/latest/ PR: ports/186881 Submitted by: Kozlov Sergey <kozlov.sergey.404@gmail.com>
Diffstat (limited to 'print/py-preppy')
-rw-r--r--print/py-preppy/Makefile19
-rw-r--r--print/py-preppy/distinfo2
-rw-r--r--print/py-preppy/pkg-descr22
3 files changed, 43 insertions, 0 deletions
diff --git a/print/py-preppy/Makefile b/print/py-preppy/Makefile
new file mode 100644
index 000000000000..060a8baa4e8c
--- /dev/null
+++ b/print/py-preppy/Makefile
@@ -0,0 +1,19 @@
+# Created by: Kozlov Sergey <kozlov.sergey.404@gmail.com>
+# $FreeBSD$
+
+PORTNAME= preppy
+PORTVERSION= 2.1.2
+CATEGORIES= print python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kozlov.sergey.404@gmail.com
+COMMENT= ReportLab's templating system
+
+LICENSE= BSD3CLAUSE
+
+USE_PYTHON= 2.7-3.3
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/print/py-preppy/distinfo b/print/py-preppy/distinfo
new file mode 100644
index 000000000000..a95078442004
--- /dev/null
+++ b/print/py-preppy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (preppy-2.1.2.tar.gz) = 6a910c03add2bd2810ef38d2da8050154da4e8e79766e08de8407382f4507d34
+SIZE (preppy-2.1.2.tar.gz) = 41065
diff --git a/print/py-preppy/pkg-descr b/print/py-preppy/pkg-descr
new file mode 100644
index 000000000000..e74197afb731
--- /dev/null
+++ b/print/py-preppy/pkg-descr
@@ -0,0 +1,22 @@
+Preppy is ReportLab's templating system. It was developed in late 2000 and has
+been in continual production use since then. It is open source (BSD-license).
+
+The key features are:
+
+- *small*. Preppy is a single Python module. If you want a templating system
+ 'in the box', it's easy to include it in your project
+- *easy to learn*. It takes about one minute to scan all the features
+- *just Python*. We have not invented another language, and if you want to do
+ something - includes, quoting, filters - you just use Python
+- *compiled to bytecode*: a .prep file gets compiled to a Python function in
+ a .pyc file
+- *easy to debug*: preppy generates proper Python exceptions, with the correct
+ line numbers for the .prep file. You can follow tracebacks from Python
+ script to Preppy template and back, through multiple includes
+- *easy to type and read*. We've been using ``{{this}}`` syntax since well
+ before Django was thought of
+- *8-bit safe*: it makes no assumption that you are generating markup and does
+ nothing unexpected with whitespace; you could use it to generate images or
+ binary files if you wanted to.
+
+WWW: http://preppy.readthedocs.org/en/latest/