aboutsummaryrefslogtreecommitdiffstats
path: root/print/py-reportlab/Makefile
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2002-07-29 15:31:50 +0800
committerperky <perky@FreeBSD.org>2002-07-29 15:31:50 +0800
commit285caabe37d142b88e8cf30ce468ba74ef692072 (patch)
treebd1389dc6b083c5415c38756ca72ca2986e4d59b /print/py-reportlab/Makefile
parent1129ea8c766cf583fb7e66eff02c262a07f8a824 (diff)
downloadfreebsd-ports-gnome-285caabe37d142b88e8cf30ce468ba74ef692072.tar.gz
freebsd-ports-gnome-285caabe37d142b88e8cf30ce468ba74ef692072.tar.zst
freebsd-ports-gnome-285caabe37d142b88e8cf30ce468ba74ef692072.zip
Added some path configuration tweaks for FreeBSD ports layout
(CMap, TrueTypeFonts and etc.)
Diffstat (limited to 'print/py-reportlab/Makefile')
-rw-r--r--print/py-reportlab/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/print/py-reportlab/Makefile b/print/py-reportlab/Makefile
index 3a6e60737ea6..e6beefbbf1d7 100644
--- a/print/py-reportlab/Makefile
+++ b/print/py-reportlab/Makefile
@@ -7,6 +7,7 @@
PORTNAME= reportlab
PORTVERSION= 1.14
+PORTREVISION= 1
CATEGORIES= print python
MASTER_SITES= ftp://ftp.reportlab.com/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,14 +20,17 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_imaging.so:${PORTSDIR}/graphics/py-imaging
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+USE_REINPLACE= yes
NO_WRKSUBDIR= yes
-REPORTLABDIR= ${PREFIX}/lib/${PYTHON_VERSION}/site-packages/reportlab
+REPORTLABDIR= ${PYTHON_SITELIBDIR}/reportlab
DOCDIR= ${PREFIX}/share/doc/reportlab
EXAMPLEDIR= ${PREFIX}/share/examples/reportlab
post-patch:
${MV} ${WRKSRC}/reportlab/lib/setup.py ${WRKDIR}
+ ${REINPLACE_CMD} 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/reportlab/rl_config.py
post-install:
${MKDIR} ${REPORTLABDIR}/fonts
@@ -37,10 +41,12 @@ post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLEDIR}
- cd ${WRKSRC}/reportlab/demos; tar cpf - * | (cd ${EXAMPLEDIR}; tar xpf -)
+ cd ${WRKSRC}/reportlab/demos; ${TAR} cpf - * | (cd ${EXAMPLEDIR}; ${TAR} xpf -)
@${MKDIR} ${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/reportlab/docs/*.pdf ${DOCDIR}
.endif
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>