aboutsummaryrefslogtreecommitdiffstats
path: root/print/splix
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-27 22:57:59 +0800
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-27 22:57:59 +0800
commit6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418 (patch)
tree95ab4f85bf7bf8cb530a6cecc47ac36a30dcab4b /print/splix
parent37e8aaec0258c9c628ea0ecb9fd1f26a00577d4b (diff)
downloadfreebsd-ports-gnome-6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418.tar.gz
freebsd-ports-gnome-6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418.tar.zst
freebsd-ports-gnome-6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418.zip
- Update security/gnutls to 3.4.10.
- Rename the LIBDANE option DANE because that's the name of the protocol supported by libgnutls-dane and gnutls-cli. Also clarify the option description. - Add an IDN option. - libgnutls-openssl has been removed in 3.4. Some ports used this library in their LIB_DEPENDS but no port actually required it. - Some old API functions have been removed. Ports that used these have been updated or patched to use the new API. - Add a patch to print/cups to prevent overlinking of libgnutls.so. - Bump PORTREVISION on dependent ports. net-im/jabber: This port used the old API to give users fine grained control over which crypto algorithms were used via a configuration file. It's not immediately obvious how to port this to the new API so the port always uses the defaults now. www/hydra: Mark BROKEN. This uses more removed calls than the other ports, is said to be alpha quality and not fully functional and has been abandoned 10 years ago. PR: 207768 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'print/splix')
-rw-r--r--print/splix/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/print/splix/Makefile b/print/splix/Makefile
index dbac762a5a48..3c43c4ba97d1 100644
--- a/print/splix/Makefile
+++ b/print/splix/Makefile
@@ -2,7 +2,7 @@
PORTNAME= splix
PORTVERSION= 2.0.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES?= print
MASTER_SITES= SF
@@ -40,14 +40,7 @@ JBIG_DESC= Enable use of JBIG algorithm (pattented)
BLACKOPTIM_DESC= Enable black correction algorithm
OPTIONS_DEFAULT= JBIG BLACKOPTIM
-.include "bsd.port.options.mk"
-
-post-patch:
- @${REINPLACE_CMD} -e '/^CC.*:= gcc/d' -e '/^CXX.*:= g++/d' \
- -e 's/make/gmake/' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's/g++/$$(CXX)/' ${WRKSRC}/rules.mk
-
-post-configure:
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MJBIG}
PPD_SAMSUNG+= ${PPD_SAMSUNG_JBIG}
@@ -65,6 +58,13 @@ MAKE_ARGS+= DISABLE_BLACKOPTIM=1
MAKE_ARGS+= CACHESIZE=${CACHESIZE}
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/^CC.*:= gcc/d' -e '/^CXX.*:= g++/d' \
+ -e 's/make/$$(MAKE)/' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} '/cups-config --libs/s/$$/ -pthread/' \
+ ${WRKSRC}/module.mk
+ @${REINPLACE_CMD} 's/g++/$$(CXX)/' ${WRKSRC}/rules.mk
+
do-install:
${MKDIR} ${STAGEDIR}${BIN_DEST_DIR}
.for MODEL in ${MODELS}