aboutsummaryrefslogtreecommitdiffstats
path: root/print/texinfo
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-07-05 02:37:28 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-07-05 02:37:28 +0800
commit2fe29f5d4ecb14ddf4013946d93d992b60d4e8c0 (patch)
tree2f65b0da5cb9fdb695db86603e331672d4ddeee8 /print/texinfo
parentb93ef479e11d8ecf1d2735b6bd71ab04a9fb6503 (diff)
downloadfreebsd-ports-gnome-2fe29f5d4ecb14ddf4013946d93d992b60d4e8c0.tar.gz
freebsd-ports-gnome-2fe29f5d4ecb14ddf4013946d93d992b60d4e8c0.tar.zst
freebsd-ports-gnome-2fe29f5d4ecb14ddf4013946d93d992b60d4e8c0.zip
Bump PORTREVISION for package change [1]
- Use REINPLACE_CMD instead of patch file PR: 220447 [1]
Diffstat (limited to 'print/texinfo')
-rw-r--r--print/texinfo/Makefile4
-rw-r--r--print/texinfo/files/patch-tp-Texinfo-MiscXS-misc.c20
2 files changed, 3 insertions, 21 deletions
diff --git a/print/texinfo/Makefile b/print/texinfo/Makefile
index 1cf14eade066..e4c0ba9f5af3 100644
--- a/print/texinfo/Makefile
+++ b/print/texinfo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= texinfo
PORTVERSION= 6.4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= print
MASTER_SITES= GNU \
@@ -40,8 +41,9 @@ NLS_USES= gettext
post-patch:
@${CP} ${DISTDIR}/${DIST_SUBDIR}/texinfo.tex ${WRKSRC}/doc/
@${INSTALL_SCRIPT} ${DISTDIR}/${DIST_SUBDIR}/texi2dvi ${WRKSRC}/util/
- @${REINPLACE_CMD} '/rm -f ..DESTDIR/s:$$: $$(DESTDIR)$$(xsdir)/XSParagraph.*:' \
+ @${REINPLACE_CMD} -e '/rm -f $$(DESTDIR)/ s|$$| $$(DESTDIR)$$(xsdir)/XSParagraph.*|' \
${WRKSRC}/tp/Texinfo/Convert/XSParagraph/Makefile.in
+ @${REINPLACE_CMD} -e 's|free (.*)|Safe&|' ${WRKSRC}/tp/Texinfo/MiscXS/misc.c
post-install:
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/htmlxref.cnf ${STAGEDIR}${DATADIR}
diff --git a/print/texinfo/files/patch-tp-Texinfo-MiscXS-misc.c b/print/texinfo/files/patch-tp-Texinfo-MiscXS-misc.c
deleted file mode 100644
index a0328a52f7c6..000000000000
--- a/print/texinfo/files/patch-tp-Texinfo-MiscXS-misc.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- tp/Texinfo/MiscXS/misc.c.orig 2017-05-02 17:05:43 UTC
-+++ tp/Texinfo/MiscXS/misc.c
-@@ -67,7 +67,7 @@ xs_abort_empty_line (HV *self, HV *curre
- additional_text = SvPV (additional_text_in, len);
- if (!SvUTF8 (additional_text_in))
- {
-- free (new_string);
-+ Safefree (new_string);
- new_string = bytes_to_utf8 (additional_text, &len);
- additional_text = new_string;
- }
-@@ -279,7 +279,7 @@ xs_merge_text (HV *self, HV *current, SV
- text = SvPV (text_in, len);
- if (!SvUTF8 (text_in))
- {
-- free (new_string);
-+ Safefree (new_string);
- new_string = bytes_to_utf8 (text, &len);
- text = new_string;
- }