aboutsummaryrefslogtreecommitdiffstats
path: root/print/transfig
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 09:20:32 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 09:20:32 +0800
commitea5fe71f77876681257f21d983643d3fe543f8b6 (patch)
treeeb10e8500ca25d687f5a16921507aea011b415f6 /print/transfig
parent6a9d87a31b9ea306304c47efd9c35d62c7bb549a (diff)
downloadfreebsd-ports-gnome-ea5fe71f77876681257f21d983643d3fe543f8b6.tar.gz
freebsd-ports-gnome-ea5fe71f77876681257f21d983643d3fe543f8b6.tar.zst
freebsd-ports-gnome-ea5fe71f77876681257f21d983643d3fe543f8b6.zip
[PATCH] print/transfig: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54950 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'print/transfig')
-rw-r--r--print/transfig/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/print/transfig/Makefile b/print/transfig/Makefile
index 73a454ed4661..457cfca3f25f 100644
--- a/print/transfig/Makefile
+++ b/print/transfig/Makefile
@@ -17,12 +17,26 @@ DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Tools to convert Xfig's .fig files
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
RUN_DEPENDS= ppmtogif:${PORTSDIR}/graphics/netpbm \
- gs:${PORTSDIR}/print/ghostscript-gnu
+ gs:${PORTSDIR}/${GSPORT}
USE_IMAKE= yes
USE_XPM= yes
MAN1= fig2dev.1 fig2ps2tex.1 pic2tpic.1 transfig.1
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
.include <bsd.port.mk>