aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-09-21 09:48:03 +0800
committerasami <asami@FreeBSD.org>2000-09-21 09:48:03 +0800
commit11379d0581ff5dcb8e249eacbdb9d33d6a8009ed (patch)
tree7a2365b949c189acc82a62ba40e3c02d7d4ff764 /print
parentaf66febf17635c4e6ac9699b860182ce1ce6e601 (diff)
downloadfreebsd-ports-gnome-11379d0581ff5dcb8e249eacbdb9d33d6a8009ed.tar.gz
freebsd-ports-gnome-11379d0581ff5dcb8e249eacbdb9d33d6a8009ed.tar.zst
freebsd-ports-gnome-11379d0581ff5dcb8e249eacbdb9d33d6a8009ed.zip
Add BUILD_DEPENDS to appropriate version of X depending on the value
of XFREE86_VERSION.
Diffstat (limited to 'print')
-rw-r--r--print/gsfonts/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/print/gsfonts/Makefile b/print/gsfonts/Makefile
index 44bbac906858..00afc408954d 100644
--- a/print/gsfonts/Makefile
+++ b/print/gsfonts/Makefile
@@ -15,8 +15,14 @@ DISTFILES= ${GS_FONTS_STD} ${GS_FONTS_OTHER}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/bin/type1inst:${PORTSDIR}/x11-fonts/p5-type1inst \
- ${X11BASE}/bin/mkfontdir:${PORTSDIR}/x11/XFree86
+BUILD_DEPENDS= ${LOCALBASE}/bin/type1inst:${PORTSDIR}/x11-fonts/p5-type1inst
+
+.include <bsd.port.pre.mk>
+.if ${XFREE86_VERSION} == 4
+BUILD_DEPENDS+= ${X11BASE}/bin/mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
+.else
+BUILD_DEPENDS+= ${X11BASE}/bin/mkfontdir:${PORTSDIR}/x11/XFree86
+.endif
NO_BUILD= yes
@@ -30,4 +36,4 @@ do-install:
${TAR} -xzf ${DISTDIR}/${GS_FONTS_STD} -C ${GSDIR}/fonts
(cd ${GSDIR}/fonts; ${LOCALBASE}/bin/type1inst -nogs -nolog -q)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>