aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-05-19 17:21:41 +0800
committerpawel <pawel@FreeBSD.org>2012-05-19 17:21:41 +0800
commit116d58efde7cced959678fa504ee222e870c0ce4 (patch)
tree9f6ea4621e93f8b2ffc30e1ea7b7dbbfd7cb9dc7 /print
parent1c23982321a695e36677d3228ffce126dd2ae41c (diff)
downloadfreebsd-ports-gnome-116d58efde7cced959678fa504ee222e870c0ce4.tar.gz
freebsd-ports-gnome-116d58efde7cced959678fa504ee222e870c0ce4.tar.zst
freebsd-ports-gnome-116d58efde7cced959678fa504ee222e870c0ce4.zip
The examplep LaTeX package provides sophisticated features
for typesetting verbatim source code listings, including the display of the source code and its compiled LaTeX or METAPOST output side-by-side, with automatic width detection and enabled page breaks (in the source), without the need for specifying the source twice. WWW: http://www.ctan.org/tex-archive/macros/latex2e/contrib/examplep PR: ports/167788 Submitted by: Hiroto Kagotani <hiroto.kagotani@gmail.com>
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/examplep/Makefile48
-rw-r--r--print/examplep/distinfo2
-rw-r--r--print/examplep/pkg-descr7
4 files changed, 58 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index ffc762c8e570..cf884c495425 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -61,6 +61,7 @@
SUBDIR += enscriptfonts
SUBDIR += epsonepl
SUBDIR += es-acroread8
+ SUBDIR += examplep
SUBDIR += fi-acroread8
SUBDIR += flpsed
SUBDIR += font-amsfonts
diff --git a/print/examplep/Makefile b/print/examplep/Makefile
new file mode 100644
index 000000000000..4fb0f0c70cab
--- /dev/null
+++ b/print/examplep/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: examplep
+# Date created: 2012-05-11
+# Whom: Hiroto Kagotani <hiroto.kagotani@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= examplep
+PORTVERSION= 0.04
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex2e/contrib/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= hiroto.kagotani@gmail.com
+COMMENT= LaTeX style files for typesetting verbatim source code listings
+
+BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX-base
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_ZIP= yes
+
+PLIST= ${WRKDIR}/pkg-plist
+
+TEXMFDIR= share/texmf-local
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+CLASSDIR= ${TEXMFDIR}/tex/latex/${PORTNAME}
+CLASS_FILES= ${PORTNAME}.sty codep.sty verbfwr.sty
+
+do-build:
+
+pre-install:
+ ${RM} -f ${PLIST}
+.for F in ${CLASS_FILES}
+ ${ECHO_CMD} "${CLASSDIR}/${F}" >> ${PLIST}
+.endfor
+ ${ECHO_CMD} "@dirrm ${CLASSDIR}" >> ${PLIST}
+ ${ECHO_CMD} "@exec ${MKTEXLSR}" >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${MKTEXLSR}" >> ${PLIST}
+
+do-install:
+ @${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${ECHO_CMD} ${CLASS_FILES}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+
+post-install:
+ ${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/examplep/distinfo b/print/examplep/distinfo
new file mode 100644
index 000000000000..85f1e453fed1
--- /dev/null
+++ b/print/examplep/distinfo
@@ -0,0 +1,2 @@
+SHA256 (examplep.zip) = 53aa06d422f6de372de2a0f40b0eb7e449a18eebb0e479a4f2881a812b06a0d6
+SIZE (examplep.zip) = 444659
diff --git a/print/examplep/pkg-descr b/print/examplep/pkg-descr
new file mode 100644
index 000000000000..cfb8f0855dce
--- /dev/null
+++ b/print/examplep/pkg-descr
@@ -0,0 +1,7 @@
+The examplep LaTeX package provides sophisticated features
+for typesetting verbatim source code listings, including the display
+of the source code and its compiled LaTeX or METAPOST output
+ side-by-side, with automatic width detection and enabled page breaks
+(in the source), without the need for specifying the source twice.
+
+WWW: http://www.ctan.org/tex-archive/macros/latex2e/contrib/examplep