aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-06-25 19:31:41 +0800
committerale <ale@FreeBSD.org>2004-06-25 19:31:41 +0800
commit1cbdc44810bd2b0af2e55429e432cb8892ef4333 (patch)
treeba2eaf856b33253025cc9457a4464362b0f15cea /print
parent40966606607a213f0a2e368c0f2cd96ad4961431 (diff)
downloadfreebsd-ports-gnome-1cbdc44810bd2b0af2e55429e432cb8892ef4333.tar.gz
freebsd-ports-gnome-1cbdc44810bd2b0af2e55429e432cb8892ef4333.tar.zst
freebsd-ports-gnome-1cbdc44810bd2b0af2e55429e432cb8892ef4333.zip
Add pecl-pdflib 2.0, a PECL extension to create PDF on the fly.
This is the new PDFLIB extension for PHP, compatible with PDFlib 6.x.
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/pecl-pdflib/Makefile34
-rw-r--r--print/pecl-pdflib/distinfo2
-rw-r--r--print/pecl-pdflib/pkg-descr7
-rw-r--r--print/pecl-pdflib/pkg-message8
-rw-r--r--print/pecl-pdflib/pkg-plist2
6 files changed, 54 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 88884b0584c7..4b431a70a2cd 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -160,6 +160,7 @@
SUBDIR += pdflib-perl
SUBDIR += pdftk
SUBDIR += pdq
+ SUBDIR += pecl-pdflib
SUBDIR += perlftlib
SUBDIR += pfbtopfa
SUBDIR += phppdflib
diff --git a/print/pecl-pdflib/Makefile b/print/pecl-pdflib/Makefile
new file mode 100644
index 000000000000..c0a2c9094931
--- /dev/null
+++ b/print/pecl-pdflib/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pecl-pdflib
+# Date created: 25 Jun 2004
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdflib
+PORTVERSION= 2.0
+CATEGORIES= print pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A PECL extension to create PDF on the fly
+
+LIB_DEPENDS= pdf.7:${PORTSDIR}/print/pdflib
+
+USE_PHP= yes
+USE_PHPIZE= yes
+
+CONFIGURE_ARGS= --with-pdflib=${LOCALBASE}
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}
+ @${INSTALL_DATA} ${WRKSRC}/modules/pdf.so \
+ ${PREFIX}/lib/php/${PHP_EXT_DIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/print/pecl-pdflib/distinfo b/print/pecl-pdflib/distinfo
new file mode 100644
index 000000000000..c459a66f01a5
--- /dev/null
+++ b/print/pecl-pdflib/distinfo
@@ -0,0 +1,2 @@
+MD5 (PECL/pdflib-2.0.tgz) = 77bb758b24827eecda521dfacf0ccd87
+SIZE (PECL/pdflib-2.0.tgz) = 22841
diff --git a/print/pecl-pdflib/pkg-descr b/print/pecl-pdflib/pkg-descr
new file mode 100644
index 000000000000..3502d2c6ec89
--- /dev/null
+++ b/print/pecl-pdflib/pkg-descr
@@ -0,0 +1,7 @@
+This extension wraps the PDFlib programming library
+for processing PDF on the fly, created by Thomas Merz.
+
+WWW: http://pecl.php.net/package/pdflib/
+
+- Alex Dupre
+ale@FreeBSD.org
diff --git a/print/pecl-pdflib/pkg-message b/print/pecl-pdflib/pkg-message
new file mode 100644
index 000000000000..0e8cd931fe91
--- /dev/null
+++ b/print/pecl-pdflib/pkg-message
@@ -0,0 +1,8 @@
+*****************************************************************************
+
+To automatically load the installed extension add the following line to
+your php.ini configuration file:
+
+extension="pdf.so"
+
+*****************************************************************************
diff --git a/print/pecl-pdflib/pkg-plist b/print/pecl-pdflib/pkg-plist
new file mode 100644
index 000000000000..e353e45ff43f
--- /dev/null
+++ b/print/pecl-pdflib/pkg-plist
@@ -0,0 +1,2 @@
+lib/php/%%PHP_EXT_DIR%%/pdf.so
+@unexec rmdir %D/lib/php/%%PHP_EXT_DIR%% 2> /dev/null || true