aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2016-05-27 05:57:29 +0800
committermandree <mandree@FreeBSD.org>2016-05-27 05:57:29 +0800
commit2a4c9517809eaa092fdfb7519fec91178011b55b (patch)
tree6a17e69dd82fbc9074f842806d1ff42975ca176e /print
parent8a29aea4b68b3be0c1e1994ef33bf98b8d96f7c5 (diff)
downloadfreebsd-ports-gnome-2a4c9517809eaa092fdfb7519fec91178011b55b.tar.gz
freebsd-ports-gnome-2a4c9517809eaa092fdfb7519fec91178011b55b.tar.zst
freebsd-ports-gnome-2a4c9517809eaa092fdfb7519fec91178011b55b.zip
Fix build on HEAD-i386, using clang 3.6, not newer.
PR: 204175 Submitted by: Hiroo Ono Reported by: Ivan Klymenko Approved by: Naram Qashat (maintainer)
Diffstat (limited to 'print')
-rw-r--r--print/fontforge/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index eef63e336895..4ccf9461e607 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -26,7 +26,8 @@ LIB_DEPENDS= libuninameslist.so:textproc/libuninameslist \
USE_GITHUB= yes
USES= autoreconf:build desktop-file-utils execinfo gettext gmake iconv \
- jpeg libtool pkgconfig python shared-mime-info shebangfix
+ jpeg libtool pkgconfig python shared-mime-info shebangfix \
+ compiler
SHEBANG_FILES= pycontrib/gdraw/__init__.py \
pycontrib/gdraw/gdraw.py
USE_XORG= ice x11 xi xkbui
@@ -80,4 +81,14 @@ pre-configure:
${LOCALBASE}/bin/gnulib-tool --aux-dir=config --m4-base=m4 --libtool --symlink --import $${gnulib_modules}' ; \
export LIBTOOLIZE=true ; ${AUTORECONF} -f -i)
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# waiting for the llvm bug to fix. http://llvm.org/bugs/show_bug.cgi?id=21903
+.if ${ARCH} == i386 && ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} > 36
+BUILD_DEPENDS+= clang36:lang/clang36
+CPP= clang-cpp36
+CC= clang36
+CXX= clang++36
+.endif
+
+.include <bsd.port.post.mk>