aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-04 03:17:39 +0800
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-04 03:17:39 +0800
commit3800f4922827c2481b31236c98367c028cabe02b (patch)
tree5669ef8c067a9d5c3d36f62d07d89d95a51b8d4d /print
parentf2a48355f395e68556669a246ec39b558a54743f (diff)
downloadfreebsd-ports-gnome-3800f4922827c2481b31236c98367c028cabe02b.tar.gz
freebsd-ports-gnome-3800f4922827c2481b31236c98367c028cabe02b.tar.zst
freebsd-ports-gnome-3800f4922827c2481b31236c98367c028cabe02b.zip
Add print/pdfchain: simple but effective GUI for pdftk
PR: 243390 Submitted by: Pierre Chapelet <chapelet@gmail.com>
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/pdfchain/Makefile35
-rw-r--r--print/pdfchain/distinfo3
-rw-r--r--print/pdfchain/pkg-descr16
-rw-r--r--print/pdfchain/pkg-plist19
5 files changed, 74 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index c1912a80c542..99448a13b5dd 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -148,6 +148,7 @@
SUBDIR += pdf-tools
SUBDIR += pdf4tcl
SUBDIR += pdfbox
+ SUBDIR += pdfchain
SUBDIR += pdflib
SUBDIR += pdflib-perl
SUBDIR += pdfstitch
diff --git a/print/pdfchain/Makefile b/print/pdfchain/Makefile
new file mode 100644
index 000000000000..f4a10d3cc6d9
--- /dev/null
+++ b/print/pdfchain/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= pdfchain
+PORTVERSION= 0.4.4.2
+CATEGORIES= print
+MASTER_SITES= https://sourceforge.net/projects/pdfchain/files/pdfchain-${PORTVERSION}/
+
+MAINTAINER= chapelet@gmail.com
+COMMENT= Graphical user interface for the PDF Toolkit (PDFtk)
+
+LICENSE= GPLv3
+
+USES= desktop-file-utils
+USES+= gettext-runtime
+USES+= gnome
+USES+= pkgconfig
+
+GNU_CONFIGURE= yes
+
+USE_GNOME= atk
+USE_GNOME+= atkmm
+USE_GNOME+= cairo
+USE_GNOME+= cairomm
+USE_GNOME+= gdkpixbuf2
+USE_GNOME+= glib20
+USE_GNOME+= glibmm
+USE_GNOME+= gtk30
+USE_GNOME+= gtkmm30
+USE_GNOME+= libsigc++20
+USE_GNOME+= pango
+USE_GNOME+= pangomm
+
+INSTALLS_ICONS= yes
+
+.include <bsd.port.mk>
diff --git a/print/pdfchain/distinfo b/print/pdfchain/distinfo
new file mode 100644
index 000000000000..5926a51e89b1
--- /dev/null
+++ b/print/pdfchain/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579170347
+SHA256 (pdfchain-0.4.4.2.tar.gz) = 1eee0f93dbe8c9cef9f9fe4ec0a10e0a45ca8cde67cd6ceffa2ce6c843752f3d
+SIZE (pdfchain-0.4.4.2.tar.gz) = 312567
diff --git a/print/pdfchain/pkg-descr b/print/pdfchain/pkg-descr
new file mode 100644
index 000000000000..511726cc7147
--- /dev/null
+++ b/print/pdfchain/pkg-descr
@@ -0,0 +1,16 @@
+This is a port of pdfchain, a graphical user interface for the PDF Toolkit
+(PDFtk). The GUI supports all common features of the command line tool in a
+comfortable way.
+
+External Dependencies =====================
+
+The PDF Chain GUI creates a PDFTK command with all required parameters and
+starts the PDFTK console program that interprets the parameters and processes
+the files. PDFTK must therefore installed at the system and executeable by the
+command "pdftk".
+
+http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/
+
+(PDF Chain starting from version 0.4.0 is compatible with PDFtk 1.45)
+
+WWW: https://sourceforge.net/projects/pdfchain/
diff --git a/print/pdfchain/pkg-plist b/print/pdfchain/pkg-plist
new file mode 100644
index 000000000000..b91ab9de84ba
--- /dev/null
+++ b/print/pdfchain/pkg-plist
@@ -0,0 +1,19 @@
+bin/pdfchain
+share/applications/pdfchain.desktop
+share/doc/pdfchain/AUTHORS
+share/doc/pdfchain/COPYING
+share/doc/pdfchain/ChangeLog
+share/doc/pdfchain/INSTALL
+share/doc/pdfchain/NEWS
+share/doc/pdfchain/README
+share/icons/hicolor/128x128/apps/pdfchain.png
+share/icons/hicolor/16x16/apps/pdfchain.png
+share/icons/hicolor/192x192/apps/pdfchain.png
+share/icons/hicolor/22x22/apps/pdfchain.png
+share/icons/hicolor/24x24/apps/pdfchain.png
+share/icons/hicolor/256x256/apps/pdfchain.png
+share/icons/hicolor/32x32/apps/pdfchain.png
+share/icons/hicolor/48x48/apps/pdfchain.png
+share/icons/hicolor/64x64/apps/pdfchain.png
+share/icons/hicolor/96x96/apps/pdfchain.png
+share/pixmaps/pdfchain.png