aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-11 22:17:00 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-11 22:17:00 +0800
commit4015ee283ae00320b5c3caf1ae21d77a6f720d0e (patch)
tree7a6a14e8a77264b92ca0ea1d01ef092f69592a22 /print
parent2a75d79821a38fad54b27cecfd0e96478177ec8f (diff)
downloadfreebsd-ports-gnome-4015ee283ae00320b5c3caf1ae21d77a6f720d0e.tar.gz
freebsd-ports-gnome-4015ee283ae00320b5c3caf1ae21d77a6f720d0e.tar.zst
freebsd-ports-gnome-4015ee283ae00320b5c3caf1ae21d77a6f720d0e.zip
- Support staging
- Use new LIB_DEPENDS syntax Approved by: portmgr blanket
Diffstat (limited to 'print')
-rw-r--r--print/gv/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/print/gv/Makefile b/print/gv/Makefile
index f5ead7f9f638..2e0e447e665e 100644
--- a/print/gv/Makefile
+++ b/print/gv/Makefile
@@ -4,17 +4,16 @@
PORTNAME= gv
PORTVERSION= 3.7.4
CATEGORIES= print
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= GNU/${PORTNAME}
MAINTAINER= bf@FreeBSD.org
COMMENT= A PostScript and PDF previewer
-LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS= libXaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
USE_XORG= xpm ice sm xext xmu x11
USE_GHOSTSCRIPT= yes
-USES= iconv gmake perl5
+USES= iconv gmake perl5 shebangfix
USE_PERL5= build
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -23,19 +22,20 @@ CONFIGURE_ENV += LDFLAGS="${LDFLAGS}" LIBS="${ICONV_LIB}"
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/X11 \
--enable-setenv-code \
--enable-SIGCHLD-fallback
+SHEBANG_FILES= ${WRKSRC}/src/gv-update-userconfig.in
-MAN1= gv.1 gv-update-userconfig.1
INFO= gv
PLIST_FILES= bin/gv \
bin/gv-update-userconfig \
%%DATADIR%%/gv_system.ad \
%%DATADIR%%/safe-gs-workdir/.keep_me \
- lib/X11/app-defaults/GV
+ lib/X11/app-defaults/GV \
+ man/man1/gv.1.gz \
+ man/man1/gv-update-userconfig.1.gz
PLIST_DIRS= %%DATADIR%%/safe-gs-workdir \
%%DATADIR%%
-NO_STAGE= yes
post-install:
- @${TOUCH} ${DATADIR}/safe-gs-workdir/.keep_me
+ @${TOUCH} ${STAGEDIR}${DATADIR}/safe-gs-workdir/.keep_me
.include <bsd.port.mk>