aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorrea <rea@FreeBSD.org>2011-03-04 21:34:09 +0800
committerrea <rea@FreeBSD.org>2011-03-04 21:34:09 +0800
commit4b2ac075b59b8a92e8a3bee757acc8346541132a (patch)
treec82f2eef2814a72d851d8238d838b23e0a05b45f /print
parent14d6b18f2313c13e34520d98cb1648f1f38f2f15 (diff)
downloadfreebsd-ports-gnome-4b2ac075b59b8a92e8a3bee757acc8346541132a.tar.gz
freebsd-ports-gnome-4b2ac075b59b8a92e8a3bee757acc8346541132a.tar.zst
freebsd-ports-gnome-4b2ac075b59b8a92e8a3bee757acc8346541132a.zip
New port: print/latex-acm
LaTeX styles for ACM publications. Feature safe: yes Approved by: garga (mentor)
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-acm/Makefile64
-rw-r--r--print/latex-acm/distinfo4
-rw-r--r--print/latex-acm/pkg-descr3
4 files changed, 72 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index b9fd34637b14..1edceabb7139 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -140,6 +140,7 @@
SUBDIR += latex
SUBDIR += latex-aa
SUBDIR += latex-aastex
+ SUBDIR += latex-acm
SUBDIR += latex-arydshln
SUBDIR += latex-auto-greek
SUBDIR += latex-beamer
diff --git a/print/latex-acm/Makefile b/print/latex-acm/Makefile
new file mode 100644
index 000000000000..9d1589cb5187
--- /dev/null
+++ b/print/latex-acm/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: latex-acm
+# Date created: Jan 25 2011
+# Whom: Eygene Ryabinkin <rea@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= latex-acm
+PORTVERSION= 1.1
+CATEGORIES= print
+MASTER_SITES= http://www.acm.org/publications/latex_style/ \
+ http://dist.codelabs.ru/fbsd/latex-acm/
+DISTFILES= acm-small-v1-1.zip \
+ acm-large-v1-1.zip
+
+MAINTAINER= rea@FreeBSD.org
+COMMENT= LaTeX styles for ACM journals
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX-base \
+ ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
+ ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+LATEXDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
+BIBTEXDIR= ${TEXMFLOCAL}/bibtex/bst/${PORTNAME:S/^latex-//}
+WRKSRC= ${WRKDIR}
+CLASS_FILES= acmlarge.cls acmsmall.cls
+STYLE_FILES= algorithm2e.sty
+BIB_FILES= acmlarge.bst acmsmall.bst
+PORTEXAMPLES= acmlarge-sample.tex acmlarge-sample.pdf acmlarge-sample.bbl \
+ acmlarge-mouse.eps acmlarge-mouse.pdf acmlarge-sam.bib \
+ acmsmall-sample.tex acmsmall-sample.pdf acmsmall-sample.bbl \
+ acmsmall-mouse.eps acmsmall-mouse.pdf acmsmall-sam.bib
+PORTDOCS= acmlarge-guide.pdf acmsmall-guide.pdf
+
+PLIST_FILES= ${CLASS_FILES:S@^@${LATEXDIR}/@} \
+ ${STYLE_FILES:S@^@${LATEXDIR}/@} \
+ ${BIB_FILES:S@^@${BIBTEXDIR}/@}
+PLIST_DIRS= ${LATEXDIR} ${BIBTEXDIR}
+PLIST_SUB= MKTEXLSR=${MKTEXLSR} \
+ TEXMFLOCAL=${TEXMFLOCAL}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${LATEXDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${LATEXDIR}
+ ${INSTALL_DATA} ${STYLE_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${LATEXDIR}
+ ${MKDIR} ${PREFIX}/${BIBTEXDIR}
+ ${INSTALL_DATA} ${BIB_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${BIBTEXDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S@^@${WRKSRC}/@} ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/print/latex-acm/distinfo b/print/latex-acm/distinfo
new file mode 100644
index 000000000000..971d08c03183
--- /dev/null
+++ b/print/latex-acm/distinfo
@@ -0,0 +1,4 @@
+SHA256 (acm-small-v1-1.zip) = 9427a99960428e176ceb9efcd1ccbfb331d9ecdf1745af4d3d499a4e2847a7dd
+SIZE (acm-small-v1-1.zip) = 271981
+SHA256 (acm-large-v1-1.zip) = 80bccaffb7843d6a537927ea9c833cc14ebf6b2111493426f0f226fccb152a8a
+SIZE (acm-large-v1-1.zip) = 338182
diff --git a/print/latex-acm/pkg-descr b/print/latex-acm/pkg-descr
new file mode 100644
index 000000000000..43f173d12d68
--- /dev/null
+++ b/print/latex-acm/pkg-descr
@@ -0,0 +1,3 @@
+LaTeX styles for ACM publications.
+
+WWW: http://www.acm.org/publications/submissions/latex_style