aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-12-12 20:40:15 +0800
committerantoine <antoine@FreeBSD.org>2017-12-12 20:40:15 +0800
commit5f53a185cae77b9a11c1bd41a8a09eae83d33f58 (patch)
tree9e9a97b3aab77d2cc63f709a61eb4142ae8b1d83 /print
parent64195de0566ff8bb9616db3341d4b2e0f4673b1f (diff)
downloadfreebsd-ports-gnome-5f53a185cae77b9a11c1bd41a8a09eae83d33f58.tar.gz
freebsd-ports-gnome-5f53a185cae77b9a11c1bd41a8a09eae83d33f58.tar.zst
freebsd-ports-gnome-5f53a185cae77b9a11c1bd41a8a09eae83d33f58.zip
- Those ports fail to build with python3
- Add some explicit FLAVOR to dependencies where needed
Diffstat (limited to 'print')
-rw-r--r--print/scribus/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index c8fff6bda1b5..394ae9cfb36a 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -24,13 +24,13 @@ LIB_DEPENDS= liblcms.so:graphics/lcms \
libcairo.so:graphics/cairo \
libhyphen.so:textproc/hyphen \
libfontconfig.so:x11-fonts/fontconfig
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter \
- ${PYTHON_SITELIBDIR}/PIL/_imaging.so:graphics/py-pillow
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
USE_QT4= corelib gui linguist_build moc_build qmake_build rcc_build uic_build xml network
USE_GNOME= libartlgpl2 libxml2
USES= cmake:outsource desktop-file-utils ghostscript:run jpeg \
- pkgconfig python shared-mime-info tar:xz
+ pkgconfig python:2.7 shared-mime-info tar:xz
USE_LDCONFIG= yes
CMAKE_ARGS+= -DWANT_HUNSPELL=YES -Wno-ferror-limit