aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
committertijl <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
commit67f12d415fec83113a7ddfbc9655db98b4e70a28 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /print
parent2088f53b95d04c86b1aece3d66aaca36ec5aaec2 (diff)
downloadfreebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.tar.gz
freebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.tar.zst
freebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.zip
Support LIBS like LDFLAGS.
- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV. - Add an option helper for LIBS. - Adjust all ports that already use LIBS. Also remove references to PTHREAD_CFLAGS and PTHREAD_LIBS while here. - Some ports did not support having a LIBS environment variable and required additional patches. Somewhat simplified a linker command line looks like: ${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS} where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and LIBS can be controlled by us. If possible -L and -l flags need to be added to LIBS to make sure they appear after any -L and -l flags set by upstream. Many ports currently add -L${LOCALBASE}/lib to LDFLAGS but this may appear too early on the command line causing installed libraries to be linked in instead of freshly built ones. Additional changes: benchmarks/netio: Replace WITH_IPV6 with an IPV6 option. comms/gnokii: Replace some patches with USES=pathfix. Also remove -fPIC. graphics/gimageview: USES=libtool and install desktop file in DESKTOPDIR. graphics/visionworkbench: Remove FreeBSD 7 support. multimedia/libmovtar: New LIB_DEPENDS syntax. multimedia/opencinematools: Use standard do-build. net/siproxd: USES=libtool:keepla (port actually needs .la files for plugins) net-mgmt/nagios: Remove -fPIC. net-mgmt/nagios4: Remove -fPIC. print/cups-base: Only add -lssp_nonshared on i386 and OSVERSION < 1000036. security/p11-kit: Replace PTHREAD_LIBS in CONFIGURE_ENV with ac_cv_func_pthread_mutexattr_init=no in CONFIGURE_ARGS. This skips a test in configure that falsely detects pthread_mutexattr_init in our libc. sysutils/dar: Fix iconv detection. x11/rxvt-unicode: Remove -lstdc++ and patch configure to remove a FreeBSD hack and use $CXX as linker as on other platforms. PR: 190592 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'print')
-rw-r--r--print/a2ps/Makefile2
-rw-r--r--print/cups-base/Makefile11
-rw-r--r--print/gv/Makefile3
-rw-r--r--print/openprinting/Makefile9
-rw-r--r--print/ttf2pt1/Makefile4
5 files changed, 12 insertions, 17 deletions
diff --git a/print/a2ps/Makefile b/print/a2ps/Makefile
index 999894284ce7..c5d71ca7241c 100644
--- a/print/a2ps/Makefile
+++ b/print/a2ps/Makefile
@@ -30,7 +30,7 @@ STRIP=
CONFIGURE_ARGS= --with-medium=libpaper --sharedstatedir=${PREFIX}/share \
--sysconfdir=${PREFIX}/etc --datadir=${PREFIX}/share \
--localstatedir=${PREFIX}/share
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+LIBS+= -L${LOCALBASE}/lib
PAPERSIZE?=
.if ${PAPERSIZE:tl} == a4
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index d7b3aa034e40..737cf4b29a8d 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -22,10 +22,9 @@ UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
USES+= gmake pkgconfig tar:bzip2
DESTDIRNAME= DSTROOT
GNU_CONFIGURE= yes
-CFLAGS+= ${PTHREAD_CFLAGS}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-DSOFLAGS= -Wl,-rpath,${PREFIX}/lib -L${PREFIX}/lib ${LDFLAGS}
+DSOFLAGS= -Wl,-rpath,${PREFIX}/lib ${LDFLAGS} ${LIBS}
CONFIGURE_ENV= DSOFLAGS="${DSOFLAGS}"
CONFIGURE_ARGS+= --localstatedir=/var \
--disable-gssapi \
@@ -80,7 +79,7 @@ COMMENT2= Library cups
INSTALL_WRKSRC= ${WRKSRC}/cups
PLIST= ${MASTERDIR}/pkg-plist.client
USES+= iconv
-LDFLAGS+= ${ICONV_LIB}
+LIBS+= ${ICONV_LIB}
USE_LDCONFIG= yes
PKGMESSAGE= ${NONEXISTENT}
DESCR= ${MASTERDIR}/pkg-descr.client
@@ -189,8 +188,6 @@ RUN_DEPENDS+= xdg-open:${PORTSDIR}/devel/xdg-utils
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MLIBUSB}
-CPPFLAGS+= -I/usr/include
-LDFLAGS+= -L/usr/lib
CONFIGURE_ARGS+= --enable-libusb
.else
CONFIGURE_ARGS+= --disable-libusb
@@ -204,7 +201,9 @@ PLIST_SUB+= WITH_ICONS=""
PLIST_SUB+= WITH_ICONS="@comment "
.endif
-CONFIGURE_ARGS+= LIBS="-lssp_nonshared"
+.if ${OSVERSION} < 1000036 && ${ARCH} == i386
+LIBS+= -lssp_nonshared
+.endif
.if ! defined(CUPS_CLIENT) && ! defined(CUPS_IMAGE)
SUB_FILES+= ulpt-cupsd.conf ulpt-cupsd.sh
diff --git a/print/gv/Makefile b/print/gv/Makefile
index 2e0e447e665e..abad5855fab5 100644
--- a/print/gv/Makefile
+++ b/print/gv/Makefile
@@ -17,8 +17,7 @@ USES= iconv gmake perl5 shebangfix
USE_PERL5= build
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV += LDFLAGS="${LDFLAGS}" LIBS="${ICONV_LIB}"
+LIBS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/X11 \
--enable-setenv-code \
--enable-SIGCHLD-fallback
diff --git a/print/openprinting/Makefile b/print/openprinting/Makefile
index 7fb009041e40..0ec97312b9a1 100644
--- a/print/openprinting/Makefile
+++ b/print/openprinting/Makefile
@@ -28,6 +28,9 @@ USE_AUTOTOOLS= aclocal autoconf autoheader automake libtool
ACLOCAL_ARGS+= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS+= -a -c
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lintl
+
# Really disable building static libraries; the package does not use
# its own libtool, and we have to tell it to stop.
# Static libraries are not very useful in this package.
@@ -45,12 +48,6 @@ MAKE_ARGS= LIBTOOL="${LIBTOOL} --tag=disable-static"
.include <bsd.port.options.mk>
-# NOTE: hard dependency on gettext() in distfiles.
-CONFIGURE_ARGS+=\
- LDFLAGS="-L${LOCALBASE}/lib" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-lintl"
-
# NOTE: This has only been tested with www/apache20, with integrated APR.
.if defined(WITH_MOD_IPP)
IGNORE= no supported apache versions available
diff --git a/print/ttf2pt1/Makefile b/print/ttf2pt1/Makefile
index 6a2759e420c0..c41af94bc153 100644
--- a/print/ttf2pt1/Makefile
+++ b/print/ttf2pt1/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
RUN_DEPENDS= t1asm:${PORTSDIR}/print/t1utils
USES= pkgconfig shebangfix perl5 uidfix
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} ${CPPFLAGS}" LIBS="${LDFLAGS}" \
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} ${CPPFLAGS}" LIBS="${LIBS}" \
INSTDIR="${STAGEDIR}${PREFIX}" LIBXDIR="${STAGEDIR}${PREFIX}/bin" \
OWNER=${BINOWN} GROUP=${BINGRP}
SHEBANG_FILES= app/TeX/sfd2map \
@@ -33,7 +33,7 @@ SHEBANG_FILES= app/TeX/sfd2map \
CPPFLAGS+= `pkg-config --cflags freetype2` \
-I${LOCALBASE}/include -DUSE_FREETYPE
-LDFLAGS+= `pkg-config --libs freetype2` \
+LIBS+= `pkg-config --libs freetype2` \
-L${LOCALBASE}/lib -lm
post-install: