aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-08-03 17:28:57 +0800
committerasami <asami@FreeBSD.org>2000-08-03 17:28:57 +0800
commit7173d932bf0cf75d5bcbb04086481211381c60da (patch)
tree908d885d09e8b3286318f830430fb053fd31da00 /print
parentf963b9d59a81b7da6d33cb040282e1323af9a317 (diff)
downloadfreebsd-ports-gnome-7173d932bf0cf75d5bcbb04086481211381c60da.tar.gz
freebsd-ports-gnome-7173d932bf0cf75d5bcbb04086481211381c60da.tar.zst
freebsd-ports-gnome-7173d932bf0cf75d5bcbb04086481211381c60da.zip
(1) Add new variable, XFREE86_VERSION, to specify which version of
XFree86 (3 or 4) to depend to when USE_XLIB is set. XFREE86_VERSION defaults to 3 for now, but adventurous users can override it in /etc/make.conf. When XFREE86_VERSION=3, USE_XLIB will add a dependency to x11/XFree86; when it is set to 4, the dependency will be to x11/XFree86-4-libraries. When XFREE86_VERSION=4, the PKG_IGNORE_DEPENDS and ALWAYS_BUILD_DEPENDS hacks to avoid messing with XFree86 are turned off. Since XFree86 version 4 includes some software that used to be separate ports, when XFREE86_VERSION=3 the following variables are provided: USE_DGS LIB_DEPENDS on x11/dgs USE_FREETYPE LIB_DEPENDS on print/freetype USE_MESA LIB_DEPENDS on graphics/Mesa3 USE_XPM LIB_DEPENDS on graphics/xpm When XFREE86_VERSION=4, these variables have no effect. The LIB_DEPENDS in the tree for the above four ports have all been converted to the USE_* counterparts. For your information, this is the count of the number of ports: USE_DGS 0 USE_FREETYPE 16 USE_MESA 36 USE_XPM 236 There is a new variable, XAWVER, which is set to 6 when XFREE86_VERSION=3 and 7 when XFREE86_VERSION=4. This is also passed to PLIST_SUB so ports that build Xaw based shared libraries can use this variable to substitute the shlib version number. There is also a provision of using a separate mtree file for XFREE86_VERSION=4, but that part is not enabled yet. Reviewed by: the ports list Tested by: make index (XFREE86_VERSION=3 only) (2) Add hebrew to list of valid categories. Submitted by: nbm
Diffstat (limited to 'print')
-rw-r--r--print/cjk-lyx/Makefile2
-rw-r--r--print/latex-cjk/Makefile2
-rw-r--r--print/lyx-devel/Makefile2
-rw-r--r--print/lyx/Makefile2
-rw-r--r--print/lyx14/Makefile2
-rw-r--r--print/lyx15/Makefile2
-rw-r--r--print/lyx16/Makefile2
-rw-r--r--print/mgv/Makefile3
-rw-r--r--print/offix-printer/Makefile4
-rw-r--r--print/perlftlib/Makefile2
-rw-r--r--print/transfig/Makefile4
11 files changed, 13 insertions, 14 deletions
diff --git a/print/cjk-lyx/Makefile b/print/cjk-lyx/Makefile
index 4a6531521995..16e4901c0e72 100644
--- a/print/cjk-lyx/Makefile
+++ b/print/cjk-lyx/Makefile
@@ -20,9 +20,9 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms \
- Xpm.4:${PORTSDIR}/graphics/xpm \
intl.1:${PORTSDIR}/devel/gettext
+USE_XPM= yes
USE_NEWGCC= yes
USE_PERL5= yes
USE_LIBTOOL= yes
diff --git a/print/latex-cjk/Makefile b/print/latex-cjk/Makefile
index 499d4b240c05..37b667f88e2b 100644
--- a/print/latex-cjk/Makefile
+++ b/print/latex-cjk/Makefile
@@ -16,12 +16,12 @@ MAINTAINER= keith@freebsd.sinica.edu.tw
BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX \
${X11BASE}/lib/X11/fonts/TrueType/bsmi00lp.ttf:${PORTSDIR}/chinese/arphicttf \
ttf2pk:${PORTSDIR}/print/freetype:build
-LIB_DEPENDS= ttf.4:${PORTSDIR}/print/freetype
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
NO_PACKAGE= "Needs ttf2pk source from FreeType"
USE_GMAKE= yes
+USE_FREETYPE= yes
WRKSRC= ${WRKDIR}/cjk-current
post-install:
diff --git a/print/lyx-devel/Makefile b/print/lyx-devel/Makefile
index 20aab60c1500..18822e8e0987 100644
--- a/print/lyx-devel/Makefile
+++ b/print/lyx-devel/Makefile
@@ -20,9 +20,9 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms \
- Xpm.4:${PORTSDIR}/graphics/xpm \
intl.1:${PORTSDIR}/devel/gettext
+USE_XPM= yes
USE_NEWGCC= yes
USE_PERL5= yes
USE_LIBTOOL= yes
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index 20aab60c1500..18822e8e0987 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -20,9 +20,9 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms \
- Xpm.4:${PORTSDIR}/graphics/xpm \
intl.1:${PORTSDIR}/devel/gettext
+USE_XPM= yes
USE_NEWGCC= yes
USE_PERL5= yes
USE_LIBTOOL= yes
diff --git a/print/lyx14/Makefile b/print/lyx14/Makefile
index 20aab60c1500..18822e8e0987 100644
--- a/print/lyx14/Makefile
+++ b/print/lyx14/Makefile
@@ -20,9 +20,9 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms \
- Xpm.4:${PORTSDIR}/graphics/xpm \
intl.1:${PORTSDIR}/devel/gettext
+USE_XPM= yes
USE_NEWGCC= yes
USE_PERL5= yes
USE_LIBTOOL= yes
diff --git a/print/lyx15/Makefile b/print/lyx15/Makefile
index 20aab60c1500..18822e8e0987 100644
--- a/print/lyx15/Makefile
+++ b/print/lyx15/Makefile
@@ -20,9 +20,9 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms \
- Xpm.4:${PORTSDIR}/graphics/xpm \
intl.1:${PORTSDIR}/devel/gettext
+USE_XPM= yes
USE_NEWGCC= yes
USE_PERL5= yes
USE_LIBTOOL= yes
diff --git a/print/lyx16/Makefile b/print/lyx16/Makefile
index 20aab60c1500..18822e8e0987 100644
--- a/print/lyx16/Makefile
+++ b/print/lyx16/Makefile
@@ -20,9 +20,9 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms \
- Xpm.4:${PORTSDIR}/graphics/xpm \
intl.1:${PORTSDIR}/devel/gettext
+USE_XPM= yes
USE_NEWGCC= yes
USE_PERL5= yes
USE_LIBTOOL= yes
diff --git a/print/mgv/Makefile b/print/mgv/Makefile
index 5f001d222e69..eedeb15c9167 100644
--- a/print/mgv/Makefile
+++ b/print/mgv/Makefile
@@ -12,9 +12,8 @@ MASTER_SITES= http://www.trends.net/~mu/srcs/
MAINTAINER= handy@physics.montana.edu
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
-
USE_X_PREFIX= yes
+USE_XPM= yes
REQUIRES_MOTIF= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= X11BASE=${X11BASE}
diff --git a/print/offix-printer/Makefile b/print/offix-printer/Makefile
index efe319450321..44e8c9fde640 100644
--- a/print/offix-printer/Makefile
+++ b/print/offix-printer/Makefile
@@ -14,12 +14,12 @@ DISTNAME= Printer-2.4
MAINTAINER= ruslan@shevchenko.kiev.ua
-LIB_DEPENDS= Dnd.1:${PORTSDIR}/x11/libdnd \
- Xpm.4:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Dnd.1:${PORTSDIR}/x11/libdnd
GNU_CONFIGURE= YES
USE_GMAKE= YES
USE_X_PREFIX= YES
+USE_XPM= YES
MAN1= printer.1
.include <bsd.port.mk>
diff --git a/print/perlftlib/Makefile b/print/perlftlib/Makefile
index 59f07251941b..b10a2848fad3 100644
--- a/print/perlftlib/Makefile
+++ b/print/perlftlib/Makefile
@@ -15,9 +15,9 @@ MASTER_SITE_SUBDIR= sada
MAINTAINER= taoka@FreeBSD.org
-LIB_DEPENDS= ttf.4:${PORTSDIR}/print/freetype
RUN_DEPENDS= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/jcode.pl:${PORTSDIR}/japanese/p5-jcode.pl
+USE_FREETYPE= yes
USE_PERL5= yes
NOMANCOMPRESS= yes
MAN1= mkttfdir.1 ftinfo.1
diff --git a/print/transfig/Makefile b/print/transfig/Makefile
index 69766f739c54..6880715fde3c 100644
--- a/print/transfig/Makefile
+++ b/print/transfig/Makefile
@@ -15,11 +15,11 @@ DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= chuckr@freebsd.org
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
- jpeg.9:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= ppmtogif:${PORTSDIR}/graphics/netpbm
USE_IMAKE= yes
+USE_XPM= yes
MAN1= fig2dev.1 fig2ps2tex.1 pic2tpic.1 transfig.1
post-patch: