aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-05-04 22:40:32 +0800
committerpav <pav@FreeBSD.org>2010-05-04 22:40:32 +0800
commit7513933bfefec2ba559aea77df324862a4915cd7 (patch)
tree41973d2d62ed68607675e59a3db0bd35caee9383 /print
parent2b97fb903064e6fd06969d1f5edbbb14fd32d000 (diff)
downloadfreebsd-ports-gnome-7513933bfefec2ba559aea77df324862a4915cd7.tar.gz
freebsd-ports-gnome-7513933bfefec2ba559aea77df324862a4915cd7.tar.zst
freebsd-ports-gnome-7513933bfefec2ba559aea77df324862a4915cd7.zip
- Fix python version in plist, detection of sane and etc
PR: ports/146181 Submitted by: Chris Petrik <chris@officialunix.com> (maintainer)
Diffstat (limited to 'print')
-rw-r--r--print/hplip3/Makefile1
-rw-r--r--print/hplip3/files/patch-core_install.py11
-rw-r--r--print/hplip3/files/patch-dcheck.py11
-rw-r--r--print/hplip3/pkg-plist4
4 files changed, 25 insertions, 2 deletions
diff --git a/print/hplip3/Makefile b/print/hplip3/Makefile
index 4ae4ddc44839..b441feba4ccc 100644
--- a/print/hplip3/Makefile
+++ b/print/hplip3/Makefile
@@ -45,6 +45,7 @@ USE_PYTHON= 25+
USE_RC_SUBR= hpssd
MAKE_JOBS_SAFE= yes
SUB_FILES= pkg-message
+USE_DOS2UNIX= yes
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/print/hplip3/files/patch-core_install.py b/print/hplip3/files/patch-core_install.py
new file mode 100644
index 000000000000..41cba9d9edcf
--- /dev/null
+++ b/print/hplip3/files/patch-core_install.py
@@ -0,0 +1,11 @@
+--- installer/core_install.py.old 2010-04-30 05:23:48.000000000 -0500
++++ installer/core_install.py 2010-04-30 05:24:07.000000000 -0500
+@@ -897,7 +897,7 @@
+
+
+ def check_sane_devel(self):
+- return len(locate_file_contains("sane.h", '/usr/include', 'extern SANE_Status sane_init'))
++ return len(locate_file_contains("sane.h", '/usr/local/include/sane', 'extern SANE_Status sane_init'))
+
+
+ def check_xsane(self):
diff --git a/print/hplip3/files/patch-dcheck.py b/print/hplip3/files/patch-dcheck.py
new file mode 100644
index 000000000000..d46ab1eba5ba
--- /dev/null
+++ b/print/hplip3/files/patch-dcheck.py
@@ -0,0 +1,11 @@
+--- installer/dcheck.py.orig 2009-08-05 09:37:17.000000000 +1200
++++ installer/dcheck.py 2009-11-27 18:53:56.000000000 +1300
+@@ -46,7 +46,7 @@
+ def update_ld_output():
+ # For library checks
+ global ld_output
+- status, ld_output = utils.run('%s -p' % os.path.join(utils.which('ldconfig'), 'ldconfig'), log_output=False)
++ status, ld_output = utils.run('%s -r' % os.path.join(utils.which('ldconfig'), 'ldconfig'), log_output=False)
+
+ if status != 0:
+ log.debug("ldconfig failed.")
diff --git a/print/hplip3/pkg-plist b/print/hplip3/pkg-plist
index e7f969546061..e9a8510b98e3 100644
--- a/print/hplip3/pkg-plist
+++ b/print/hplip3/pkg-plist
@@ -1418,8 +1418,8 @@ share/applications/hplip.desktop
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications
@dirrmtry lib/sane
-@dirrmtry lib/python2.5/site-packages
-@dirrmtry lib/python2.5
+@dirrmtry lib/%%PYTHON_VERSION%%/site-packages
+@dirrmtry lib/%%PYTHON_VERSION%%
@dirrmtry libexec/cups/filter
@dirrmtry libexec/cups/backends
@dirrmtry libexec/cups