aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2005-02-05 12:59:26 +0800
committerAkinori MUSHA <knu@FreeBSD.org>2005-02-05 12:59:26 +0800
commit870baf2a9ac76ec39ea9fa066418657fb53ede54 (patch)
tree49251f8ea7663d5f4d431ea8b3f43c4eaf180b23 /print
parentbba475b325efa2e3cc7a22fefe97cff615fa7a3a (diff)
downloadfreebsd-ports-gnome-870baf2a9ac76ec39ea9fa066418657fb53ede54.tar.gz
freebsd-ports-gnome-870baf2a9ac76ec39ea9fa066418657fb53ede54.tar.zst
freebsd-ports-gnome-870baf2a9ac76ec39ea9fa066418657fb53ede54.zip
The slippery pthread support for systems prior to 502102 has been
dropped and the lang/ruby16_r and lang/ruby18_r ports have been removed, since no one seems to appreciate the partially working solution. Good news is that the pthread support of lang/ruby18 is now enabled by default for newer systems, which means the ruby interpreter is linked with libpthread. This will allow threaded extension libraries to run and work properly on those systems. The --march=cputype flag is disabled because it gets ruby to malfunction and fail to build. I don't know if the problem is in libpthread or in gcc. (It really makes me wonder if they had actually tested before asking me to do this somewhat risky change ;-)
Diffstat (limited to 'print')
-rw-r--r--print/ruby-panda/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/print/ruby-panda/Makefile b/print/ruby-panda/Makefile
index e69137a616a2..c223acb1c88e 100644
--- a/print/ruby-panda/Makefile
+++ b/print/ruby-panda/Makefile
@@ -7,6 +7,7 @@
PORTNAME= panda
PORTVERSION= 0.0.7
+PORTREVISION= 1
CATEGORIES= print ruby
MASTER_SITES= http://www2s.biglobe.ne.jp/~Nori/ruby/dist/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -23,7 +24,6 @@ LIB_DEPENDS= panda.0:${PORTSDIR}/print/panda \
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-RUBY_WITH_PTHREAD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
INSTALL_TARGET= site-install
@@ -34,6 +34,11 @@ DOCS_JA= ChangeLog.ja README.ja TODO.ja \
doc/ref_ja.html doc/ref_ja.rd
EXAMPLES_EN= circles.rb main.rb morecircles.rb template.rb
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 502102
+BROKEN= "Systems prior to FreeBSD 502102 are out of support"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
@@ -50,4 +55,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>