aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-10-18 17:44:20 +0800
committeralane <alane@FreeBSD.org>2002-10-18 17:44:20 +0800
commit87802353f50d179c84af500db04d9b130538717a (patch)
tree2aebed6589c75255f585497c8ce229b8dfa86dff /print
parent597cb88310c5c5f3d06f8f580203dd5fdf8f1262 (diff)
downloadfreebsd-ports-gnome-87802353f50d179c84af500db04d9b130538717a.tar.gz
freebsd-ports-gnome-87802353f50d179c84af500db04d9b130538717a.tar.zst
freebsd-ports-gnome-87802353f50d179c84af500db04d9b130538717a.zip
It's still BORKED, IN PROGRESS, MEN WORKING, THIS TRAIN WILL BE OUT OF
SERVICE UNTIL DEC 3008. State backup.
Diffstat (limited to 'print')
-rw-r--r--print/cups/Makefile.common10
-rw-r--r--print/cups/Makefile.man45
2 files changed, 25 insertions, 30 deletions
diff --git a/print/cups/Makefile.common b/print/cups/Makefile.common
index 8d25ac89cbdb..012ea502c478 100644
--- a/print/cups/Makefile.common
+++ b/print/cups/Makefile.common
@@ -61,15 +61,11 @@ CONFIGURE_ARGS+= \
--with-cups-user=${CUPS_USER} --with-cups-group=${CUPS_GROUP} \
--with-rcdir=${PREFIX}/etc/rc.d --without-pam
-COMPONENT= ${PORTNAME}
-MAKE_ARGS+= COMPONENT=${COMPONENT}
-
post-patch::
- ${RM} -f ${WRKSRC}/man/Makefile
- ${CP} -f ${.CURDIR}/../../print/cups/man-Makefile \
+ ${RM} -f ${WRKSRC}/man/Makefile ${WRKSRC}/man/Makefile.common
+ ${TOUCH} ${WRKSRC}/man/Makefile.common
+ ${CP} -f ${.CURDIR}/../../print/cups/Makefile.man \
${WRKSRC}/man/Makefile
- ${CP} -f ${FILESDIR}/manfiles.${COMPONENT} \
- ${WRKSRC}/man/manfiles.${COMPONENT}
cd ${WRKSRC}; ${AUTOCONF} --force
.endif # ${PORTNAME} != "cups"
diff --git a/print/cups/Makefile.man b/print/cups/Makefile.man
index 8f1814c60e83..0e05e35609e2 100644
--- a/print/cups/Makefile.man
+++ b/print/cups/Makefile.man
@@ -2,7 +2,7 @@
# "$Id: Makefile,v 1.21 2002/05/21 19:59:41 mike Exp $"
#
# [============================================================
-# $FreeBSD$
+# $FreeBSD$
# Heavily re-written by AlanE at FreeBSD to make it simpler for
# us. How this works out is yet to be seen.
# ============================================================]
@@ -35,18 +35,7 @@ include Makefile.common
# Other languages...
#
-LANGDIRS = fr
-
-#
-# Component specific lists
-#
-
-MAN1=
-MAN3=
-MAN5=
-MAN8=
-
-include manfiles.${COMPONENT}
+LANGDIRS = #fr
#
# List of installable files
@@ -58,34 +47,44 @@ MANFILES= $(MAN1) $(MAN3) $(MAN5) $(MAN8)
# Make installable files
#
-all: $(MANFILES)
+all:
#
# Clean up generated files
#
clean:
- ${RM} -f $(MANFILES)
+
#
# Dummy depend target...
#
depend:
-
#
# Install files...
#
-install: all
- do-install
-# for dir in $(LANGDIRS); do \
-# echo "Installing all in man/$$dir..."; \
-# (cd $$dir; make install); \
-# done
+install: do-install
+ for dir in $(LANGDIRS); do \
+ echo "Installing all in man/$$dir..."; \
+ (cd $$dir; make install); \
+ done
do-install: all
- true
+ for i in $(MAN1); do
+ ${INSTALL_MAN} $${i%?}man ${MAN_PREFIX}/man/man1/$$i
+ done
+ for i in $(MAN3); do
+ ${INSTALL_MAN} $${i%?}man ${MAN_PREFIX}/man/man1/$$i
+ done
+ for i in $(MAN5); do
+ ${INSTALL_MAN} $${i%?}man ${MAN_PREFIX}/man/man1/$$i
+ done
+ for i in $(MAN8); do
+ ${INSTALL_MAN} $${i%?}man ${MAN_PREFIX}/man/man1/$$i
+ done
+
#
# End of "$Id: Makefile,v 1.21 2002/05/21 19:59:41 mike Exp $".