aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-10 11:24:09 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-10 11:24:09 +0800
commit8a6f7165845cd21397a59eae6b1f3e7a941cdbb3 (patch)
treedba98007ce8af942977ac3e2ead4dfa0c7dc47c1 /print
parent1f32a9d6725f17789e069f0a588e73864c89e66c (diff)
downloadfreebsd-ports-gnome-8a6f7165845cd21397a59eae6b1f3e7a941cdbb3.tar.gz
freebsd-ports-gnome-8a6f7165845cd21397a59eae6b1f3e7a941cdbb3.tar.zst
freebsd-ports-gnome-8a6f7165845cd21397a59eae6b1f3e7a941cdbb3.zip
Stagify.
Diffstat (limited to 'print')
-rw-r--r--print/font2svg/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/print/font2svg/Makefile b/print/font2svg/Makefile
index 25303225aea7..b85c1ae131e4 100644
--- a/print/font2svg/Makefile
+++ b/print/font2svg/Makefile
@@ -18,16 +18,15 @@ NO_BUILD= yes
PLIST_FILES= bin/font2svg %%DATADIR%%/encodings %%DATADIR%%/font2svg.ps
PLIST_DIRS= %%DATADIR%%
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s|^#!/bin/bash|#!/usr/bin/env bash| ; \
s|^font2svg_home=.*$$|font2svg_home=${DATADIR}|" \
${WRKSRC}/font2svg.sh
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/font2svg.sh ${PREFIX}/bin/font2svg
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/encodings ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/font2svg.ps ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/font2svg.sh ${STAGEDIR}${PREFIX}/bin/font2svg
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/encodings ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/font2svg.ps ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>