aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-05-11 00:46:36 +0800
committertijl <tijl@FreeBSD.org>2016-05-11 00:46:36 +0800
commit94d8e29d5d1e1c140e0350df978cd543cc2f65e3 (patch)
treeef9343b1ae09c5b23fd8b6d148772b8be7589377 /print
parent2b37920a5c22b0d03fa38b50fb6bff6c032d9281 (diff)
downloadfreebsd-ports-gnome-94d8e29d5d1e1c140e0350df978cd543cc2f65e3.tar.gz
freebsd-ports-gnome-94d8e29d5d1e1c140e0350df978cd543cc2f65e3.tar.zst
freebsd-ports-gnome-94d8e29d5d1e1c140e0350df978cd543cc2f65e3.zip
Some plugins have an SONAME field that is different from the library name
so the wrapper library that links to such a plugin cannot find it at runtime. Create dummy plugins without SONAME and link the wrapper libraries against that. PR: 209426 Tested by: Andreas Beck <jarles.live@gmail.com>
Diffstat (limited to 'print')
-rw-r--r--print/hplip-plugin/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/print/hplip-plugin/Makefile b/print/hplip-plugin/Makefile
index 61d4b852b924..5d64663e93b7 100644
--- a/print/hplip-plugin/Makefile
+++ b/print/hplip-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hplip-plugin
PORTVERSION= 3.16.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= http://hplipopensource.com/hplip-web/plugin/
DISTNAME= hplip-${DISTVERSION}-plugin
@@ -46,10 +46,14 @@ do-extract:
--keep --noexec --nox11 --target ${WRKSRC}
do-build:
- ${CC} ${CFLAGS} -Wall -fPIC -c ${FILESDIR}/wrap.c -o ${WRKSRC}/wrap.o
+ ${MKDIR} ${WRKSRC}/build
+ ${CC} ${CFLAGS} -Wall -fPIC -c ${FILESDIR}/wrap.c \
+ -o ${WRKSRC}/build/wrap.o
.for p in ${PLUGINS}
- (cd ${WRKSRC} && ${BRANDELF} -t FreeBSD ${p:T}-${LINARCH}.so && \
- ${CC} ${CFLAGS} ${LDFLAGS} -shared -fPIC -o ${p:T}.so wrap.o \
+ ${BRANDELF} -t FreeBSD ${WRKSRC}/${p:T}-${LINARCH}.so
+ (cd ${WRKSRC}/build \
+ && ${CC} -shared -fPIC -o ${p:T}-${LINARCH}.so wrap.o \
+ && ${CC} ${CFLAGS} ${LDFLAGS} -shared -fPIC -o ${p:T}.so wrap.o \
${p:T}-${LINARCH}.so -Wl,-rpath,${PREFIX}/share/hplip/${p:H})
.endfor
@@ -62,7 +66,7 @@ do-install:
# -m 555 because HPLIP checks that the plugins are +x.
${INSTALL_LIB} -m 555 ${WRKSRC}/${p:T}-${LINARCH}.so \
${STAGEDIR}${PREFIX}/share/hplip/${p}-${LINARCH}.so
- ${INSTALL_LIB} -m 555 ${WRKSRC}/${p:T}.so \
+ ${INSTALL_LIB} -m 555 ${WRKSRC}/build/${p:T}.so \
${STAGEDIR}${PREFIX}/share/hplip/${p}.so
.endfor
${INSTALL_DATA} ${WRKSRC}/plugin.spec ${STAGEDIR}${PREFIX}/share/hplip