aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2014-11-23 16:34:39 +0800
committerhrs <hrs@FreeBSD.org>2014-11-23 16:34:39 +0800
commit974053393aee1bd31379c64e219fdb8523fdac56 (patch)
tree2ed4605346a5b764be9a7c863bef9d96b443828e /print
parent0b5a1d7ff9db9543dc4ca6d006f7897981270d8b (diff)
downloadfreebsd-ports-gnome-974053393aee1bd31379c64e219fdb8523fdac56.tar.gz
freebsd-ports-gnome-974053393aee1bd31379c64e219fdb8523fdac56.tar.zst
freebsd-ports-gnome-974053393aee1bd31379c64e219fdb8523fdac56.zip
- Strip binaries properly.
- Update pkg-message.
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript9/Makefile2
-rw-r--r--print/ghostscript9/files/patch-base-Makefile.in27
-rw-r--r--print/ghostscript9/files/patch-base-unixinst.mak17
-rw-r--r--print/ghostscript9/files/pkg-message.in4
4 files changed, 29 insertions, 21 deletions
diff --git a/print/ghostscript9/Makefile b/print/ghostscript9/Makefile
index ff1fbcce9688..82d18a700427 100644
--- a/print/ghostscript9/Makefile
+++ b/print/ghostscript9/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ghostscript
PORTVERSION= 9.06
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= print
MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
diff --git a/print/ghostscript9/files/patch-base-Makefile.in b/print/ghostscript9/files/patch-base-Makefile.in
index a191e8947e82..93eddf3d998f 100644
--- a/print/ghostscript9/files/patch-base-Makefile.in
+++ b/print/ghostscript9/files/patch-base-Makefile.in
@@ -1,18 +1,19 @@
---- base/Makefile.in.orig 2012-02-08 17:48:48.000000000 +0900
-+++ base/Makefile.in 2012-02-13 11:01:06.000000000 +0900
-@@ -48,9 +48,8 @@
+--- base/Makefile.in.orig 2012-08-08 17:01:36.000000000 +0900
++++ base/Makefile.in 2014-11-23 17:28:38.000000000 +0900
+@@ -49,9 +49,9 @@
# the directories also define the default search path for the
# initialization files (gs_*.ps) and the fonts.
-INSTALL = $(GLSRCDIR)/instcopy -c
-INSTALL_PROGRAM = $(INSTALL) -m 755
-INSTALL_DATA = $(INSTALL) -m 644
-+INSTALL_PROGRAM = ${BSD_INSTALL_SCRIPT}
++INSTALL_PROGRAM = ${BSD_INSTALL_PROGRAM}
++INSTALL_SCRIPT = ${BSD_INSTALL_SCRIPT}
+INSTALL_DATA = ${BSD_INSTALL_DATA}
INSTALL_SHARED = @INSTALL_SHARED@
prefix = @prefix@
-@@ -201,7 +200,7 @@
+@@ -202,7 +202,7 @@
# some older JPEG streams that violate the standard. If the JPEG
# library built from local sources, the patch will be applied.
@@ -21,7 +22,7 @@
JPEG_NAME=jpeg
# Define the directory where the PNG library sources are stored,
-@@ -209,12 +208,12 @@
+@@ -210,12 +210,12 @@
# You may need to change this if the libpng version changes.
# See png.mak for more information.
@@ -36,7 +37,7 @@
TIFFSRCDIR=@LIBTIFFDIR@
TIFFPLATFORM=unix
TIFFCONFIG_SUFFIX=
-@@ -223,7 +222,7 @@
+@@ -224,7 +224,7 @@
# Define the directory where the zlib sources are stored.
# See zlib.mak for more information.
@@ -45,7 +46,7 @@
ZSRCDIR=@ZLIBDIR@
#ZLIB_NAME=gz
ZLIB_NAME=z
-@@ -250,7 +249,7 @@
+@@ -251,7 +251,7 @@
JPX_LIB=@JPX_DECODER@
SHARE_JPX=@SHARE_JPX@
JPXSRCDIR=@JPXDIR@
@@ -54,7 +55,7 @@
# uncomment the following three lines and one of the last two to
# compile in the Luratech lwf_jp2 codec
-@@ -330,7 +329,7 @@
+@@ -331,7 +331,7 @@
# Define the added flags for standard, debugging, profiling
# and shared object builds.
@@ -63,7 +64,7 @@
CFLAGS_DEBUG=@DBG_CFLAGS@
CFLAGS_PROFILE=-pg @OPT_CFLAGS@
CFLAGS_SO=@DYNAMIC_CFLAGS@
-@@ -381,7 +380,7 @@
+@@ -382,7 +382,7 @@
# Solaris may need -lnsl -lsocket -lposix4.
# (Libraries required by individual drivers are handled automatically.)
@@ -72,7 +73,7 @@
# Define the standard libraries to search at the end of linking.
# Most platforms require -lpthread for the POSIX threads library;
-@@ -425,7 +424,7 @@
+@@ -426,7 +426,7 @@
# the pthread library. Otherwise use SYNC=nosync
#SYNC=posync
#SYNC=nosync
@@ -81,7 +82,7 @@
# programs we use
RM=rm -f
-@@ -513,27 +512,27 @@
+@@ -518,27 +518,27 @@
#DEVICE_DEVS20=$(DD)cljet5.dev $(DD)cljet5c.dev
#DEVICE_DEVS21=$(DD)spotcmyk.dev $(DD)devicen.dev $(DD)xcf.dev $(DD)psdcmyk.dev $(DD)psdrgb.dev
DEVICE_DEVS=$(DISPLAY_DEV) @X11_DEVS@
@@ -130,7 +131,7 @@
# Shared library target to build.
-@@ -578,6 +577,7 @@
+@@ -583,6 +583,7 @@
# ---------------- End of platform-specific section ---------------- #
INSTALL_CONTRIB=@INSTALL_CONTRIB@
diff --git a/print/ghostscript9/files/patch-base-unixinst.mak b/print/ghostscript9/files/patch-base-unixinst.mak
index 013836f8afe2..51d6baa31dad 100644
--- a/print/ghostscript9/files/patch-base-unixinst.mak
+++ b/print/ghostscript9/files/patch-base-unixinst.mak
@@ -1,11 +1,20 @@
---- base/unixinst.mak.orig 2007-08-15 05:48:29.000000000 +0900
-+++ base/unixinst.mak 2008-05-05 16:48:06.000000000 +0900
-@@ -128,7 +128,7 @@
+--- base/unixinst.mak.orig 2012-08-08 17:01:36.000000000 +0900
++++ base/unixinst.mak 2014-11-23 17:29:15.000000000 +0900
+@@ -45,7 +45,7 @@
+ wftopfa fixmswrd.pl lprsetup.sh pj-gs.sh pv.sh sysvlp.sh unix-lpr.sh ;\
+ do if ( test -f $(PSLIBDIR)/$$f ); then \
+ (cat $(PSLIBDIR)/$$f | sed -e "s/GS_EXECUTABLE=gs/GS_EXECUTABLE=$(GS)/" > $(PSOBJDIR)/$$f); \
+- $(INSTALL_PROGRAM) $(PSOBJDIR)/$$f $(DESTDIR)$(scriptdir)/$$f; \
++ $(INSTALL_SCRIPT) $(PSOBJDIR)/$$f $(DESTDIR)$(scriptdir)/$$f; \
+ fi;\
+ done'
+
+@@ -142,7 +142,7 @@
done'
# install the man pages for each locale
-MAN_LCDIRS=. de
+MAN_LCDIRS=.
MAN1_LINKS_PS2PS=eps2eps
- MAN1_LINKS_PS2PDF=ps2pdf12 ps2pdf13
+ MAN1_LINKS_PS2PDF=ps2pdf12 ps2pdf13 ps2pdf14
MAN1_LINKS_GSLP=gsbj gsdj gsdj500 gslj
diff --git a/print/ghostscript9/files/pkg-message.in b/print/ghostscript9/files/pkg-message.in
index ac37ac57ae23..ea0381cc7d91 100644
--- a/print/ghostscript9/files/pkg-message.in
+++ b/print/ghostscript9/files/pkg-message.in
@@ -1,7 +1,5 @@
Note: in order to use the script "dvipdf", dvips must be installed.
-This program may be provided by either print/dvips or print/dvipsk-tetex
-(print/dvipsk-tetex may be preferable since it doesn't conflict with
-tetex things).
+This program is provided by another package print/tex-dvipsk.
FAPIfontmap and FAPIcidfmap in %%DATADIR%%/%%PORTVERSION%%/Resource/Init
have to be configured if you want to use FAPI feature.