aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorkeramida <keramida@FreeBSD.org>2009-06-02 15:06:34 +0800
committerkeramida <keramida@FreeBSD.org>2009-06-02 15:06:34 +0800
commit9812fb3bdbc1c65ee6df751cf14384a36c701b44 (patch)
tree35ed8811d10f55f3effe860d58fd0501341ffe02 /print
parent3109cc60d35f80aa8a419f00c918ef4ae2a5405f (diff)
downloadfreebsd-ports-gnome-9812fb3bdbc1c65ee6df751cf14384a36c701b44.tar.gz
freebsd-ports-gnome-9812fb3bdbc1c65ee6df751cf14384a36c701b44.tar.zst
freebsd-ports-gnome-9812fb3bdbc1c65ee6df751cf14384a36c701b44.zip
Allow building ghostscript8 without CUPS support. The default is
to link with CUPS, but it should now be possible to `make config' and disable any link options that refer to CUPS libraries. Approved by: doceng (hrs) Noticed by: Stefan Thurner thurners at nicsys.de Guido Falsi mad at madpilot.net [1], Helge Oldach ports-ghostscript8-may09 at oldach.net [1] [1] An almost identical patch was submitted to doceng.
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript8/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index fcfdc679a308..02e95fe1f6bf 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghostscript8
PORTVERSION= 8.64
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/$/:gs_srcs/} \
ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/GPL/gs${PORTVERSION:S/.//}/:gs_srcs \
@@ -22,8 +22,7 @@ MAINTAINER= doceng@FreeBSD.org
COMMENT= Ghostscript 8.x PostScript interpreter
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- cupsimage.2:${PORTSDIR}/print/cups-image
+ png.5:${PORTSDIR}/graphics/png
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME:S,8,,}/fonts/a010013l.pfb:${PORTSDIR}/print/gsfonts
CONFLICTS= gambc-[0-9]* ghostscript7-[0-9]* ghostscript7-*-[0-9]*
@@ -58,6 +57,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
DATADIR= ${PREFIX}/share/${PORTNAME:S,8$,,}
OPTIONS= A4SIZE "Set A4 (not Letter) as a default paper size" off \
+ CUPS "Enable CUPS support" on \
FONTCONFIG "fontconfig support" on \
FT_BRIDGE "FreeType bridge" off \
X11 "X11 support" on
@@ -86,6 +86,13 @@ PLIST_SUB+= GS_${D}="@comment "
.endif
.endfor
+.if !defined(WITHOUT_CUPS)
+LIB_DEPENDS+= libcupsimage.so.2:${PORTSDIR}/print/cups-base
+CONFIGURE_ARGS+= --enable-cups
+.else
+CONFIGURE_ARGS+= --disable-cups
+.endif
+
.if !defined(WITHOUT_GS_dmprt)
.include "${FILESDIR}/Makefile.dmprt"
.endif