aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-12-19 03:49:56 +0800
committerPawel Pekala <pawel@FreeBSD.org>2014-12-19 03:49:56 +0800
commitb724d6bfb1459eaf796fe772bdd6c2a80808d223 (patch)
treeb1ee7bc5edccd619e535a45a8a9c9083fd4c7728 /print
parent7c19fe99e4468dc045270ebafa538c9c99500469 (diff)
downloadfreebsd-ports-gnome-b724d6bfb1459eaf796fe772bdd6c2a80808d223.tar.gz
freebsd-ports-gnome-b724d6bfb1459eaf796fe772bdd6c2a80808d223.tar.zst
freebsd-ports-gnome-b724d6bfb1459eaf796fe772bdd6c2a80808d223.zip
- Revive print/lgrind, now distributed as one file
- Add new mastersite, homepage, staging support - Clean pkg-plist PR: 195437 Submitted by: Henry Hu <henry.hu.sh@gmail.com>
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/lgrind/Makefile37
-rw-r--r--print/lgrind/distinfo2
-rw-r--r--print/lgrind/files/patch-Makefile25
-rw-r--r--print/lgrind/files/patch-lgutil_c20
-rw-r--r--print/lgrind/files/patch-source_Makefile12
-rw-r--r--print/lgrind/files/patch-source_lgrind.c11
-rw-r--r--print/lgrind/files/patch-source_regexp.c11
-rw-r--r--print/lgrind/pkg-descr9
-rw-r--r--print/lgrind/pkg-plist6
10 files changed, 134 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 9f9fe1ee4e5e..fa42ba9a9d55 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -109,6 +109,7 @@
SUBDIR += latex-resume
SUBDIR += latex2rtf
SUBDIR += latexdiff
+ SUBDIR += lgrind
SUBDIR += libgnomecups
SUBDIR += libgnomeprint
SUBDIR += libgnomeprint-reference
diff --git a/print/lgrind/Makefile b/print/lgrind/Makefile
new file mode 100644
index 000000000000..25f5e4635830
--- /dev/null
+++ b/print/lgrind/Makefile
@@ -0,0 +1,37 @@
+# Created by: Kay Lehmann
+# $FreeBSD$
+
+PORTNAME= lgrind
+PORTVERSION= 3.67
+PORTREVISION= 8
+CATEGORIES= print
+MASTER_SITES= http://mirrors.ctan.org/support/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Produce beautiful listings of source code with LaTeX
+
+USE_TEX= latex texhash
+
+USES= zip
+
+RESTRICTED= According to the README-file there is a license issue \
+ because of non-free code. Check the README file within \
+ the source tarball. No response from author of some code \
+ this port is based on.
+
+post-patch:
+# PREFIX safeness
+ @${REINPLACE_CMD} -E \
+ -e s'|^(BASEDIR).*$$|\1=${STAGEDIR}${PREFIX}|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E \
+ -e s'|%%PREFIX%%|${PREFIX}|' \
+ ${WRKSRC}/Makefile
+# C{C,FLAGS} safeness
+ @${REINPLACE_CMD} -E \
+ -e s'|^(CC).*$$|\1=${CC}|' \
+ -e s'|^(CFLAGS).*$$|\1=${CFLAGS}|' \
+ ${WRKSRC}/source/Makefile
+
+.include <bsd.port.mk>
diff --git a/print/lgrind/distinfo b/print/lgrind/distinfo
new file mode 100644
index 000000000000..373a34d01e20
--- /dev/null
+++ b/print/lgrind/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lgrind.zip) = f946615b77f790e8f43b857d268fa705b2f76a8d986e3f10025a5c2f67b11074
+SIZE (lgrind.zip) = 245984
diff --git a/print/lgrind/files/patch-Makefile b/print/lgrind/files/patch-Makefile
new file mode 100644
index 000000000000..3b5b39fe8bda
--- /dev/null
+++ b/print/lgrind/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig 2001-11-04 11:24:00.000000000 -0500
++++ Makefile 2014-12-16 19:19:03.000000000 -0500
+@@ -4,9 +4,10 @@
+
+ BASEDIR=/usr
+ #DEFSFILE=${HOME}/Work/lgrind/lgrindef
+-DEFSFILE=$(BASEDIR)/share/texmf/tex/latex/lgrind/lgrindef
+-TEXFILEDIR=$(BASEDIR)/share/texmf/tex/latex/lgrind
+-DOCDIR=$(BASEDIR)/doc/lgrind
++DEFSFILE=$(BASEDIR)/share/texmf-dist/tex/latex/lgrind/lgrindef
++DEFSFILE_REAL=%%PREFIX%%/share/texmf-dist/tex/latex/lgrind/lgrindef
++TEXFILEDIR=$(BASEDIR)/share/texmf-dist/tex/latex/lgrind
++DOCDIR=$(BASEDIR)/share/texmf-dist/doc/latex/lgrind
+
+ INSTALL=install
+ SOURCES=lgrind.c lgutil.c regexp.c regexp.h lgrindef.c lgrindef.h retest.c v2lg.c
+@@ -28,7 +29,7 @@
+
+ lgrind:
+ cd source; \
+- make DEFSFILE=$(DEFSFILE) BASEDIR=$(BASEDIR) INSTALL=$(INSTALL) VERSION=$(VERSION)
++ make DEFSFILE=$(DEFSFILE_REAL) BASEDIR=$(BASEDIR) INSTALL=$(INSTALL) VERSION=$(VERSION)
+
+ clean:
+ rm -f lgrind.log
diff --git a/print/lgrind/files/patch-lgutil_c b/print/lgrind/files/patch-lgutil_c
new file mode 100644
index 000000000000..35c0002250b1
--- /dev/null
+++ b/print/lgrind/files/patch-lgutil_c
@@ -0,0 +1,20 @@
+--- source/lgutil.c.orig 2001-11-04 11:24:00.000000000 -0500
++++ source/lgutil.c 2014-11-26 20:33:37.000000000 -0500
+@@ -113,7 +113,7 @@
+ check=0;
+ if (*config=='\n' || config[strlen(config)-2]!='\\')
+ check=1;
+- if (fgets(config, BUFFERSIZE, tf)==NULL) break;
++ if (fgets(config, sizeof config, tf)==NULL) break;
+ if (check!=0) AddToLList(config, &currlch, &llch);
+ } while (strcmp((*currlch).name, "EndOfLanguageDefinitions")!=0);
+ rch=lch;
+@@ -277,7 +277,7 @@
+ char linebuf[201], *cp;
+ varsubst *varsubsts=NULL, *substitem, *substlistpos;
+
+- if (f==NULL) return;
++ if (f==NULL) return NULL;
+ while (!feof(f))
+ {
+ fscanf(f, "%200[^\n]", linebuf);
diff --git a/print/lgrind/files/patch-source_Makefile b/print/lgrind/files/patch-source_Makefile
new file mode 100644
index 000000000000..0d764fd56dba
--- /dev/null
+++ b/print/lgrind/files/patch-source_Makefile
@@ -0,0 +1,12 @@
+--- source/Makefile.orig Sat Apr 20 15:18:16 2002
++++ source/Makefile Sat Apr 20 15:21:27 2002
+@@ -33,7 +33,9 @@
+ install: all
+ $(INSTALL) -s lgrind $(BINDIR)/lgrind
+ $(INSTALL) -m 644 $(MANPAGES1) $(MANDIR)/man1
++ gzip $(MANDIR)/man1/$(MANPAGES1)
+ $(INSTALL) -m 644 $(MANPAGES5) $(MANDIR)/man5
++ gzip $(MANDIR)/man5/$(MANPAGES5)
+
+ clean:
+ rm -f $(OBJS) lgrind retest v2lg
diff --git a/print/lgrind/files/patch-source_lgrind.c b/print/lgrind/files/patch-source_lgrind.c
new file mode 100644
index 000000000000..27392f0450bb
--- /dev/null
+++ b/print/lgrind/files/patch-source_lgrind.c
@@ -0,0 +1,11 @@
+--- source/lgrind.c.orig Fri Mar 28 10:08:41 2003
++++ source/lgrind.c Fri Mar 28 10:09:12 2003
+@@ -94,7 +94,7 @@
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <string.h>
+-#include <malloc.h>
++/*#include <malloc.h> */
+ #include <time.h>
+ /* One of the following two (depending on your system) */
+ #include <unistd.h>
diff --git a/print/lgrind/files/patch-source_regexp.c b/print/lgrind/files/patch-source_regexp.c
new file mode 100644
index 000000000000..708207ffbc95
--- /dev/null
+++ b/print/lgrind/files/patch-source_regexp.c
@@ -0,0 +1,11 @@
+--- source/regexp.c.orig Fri Mar 28 10:09:46 2003
++++ source/regexp.c Fri Mar 28 10:10:13 2003
+@@ -56,7 +56,7 @@
+
+
+ #include <stdio.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <ctype.h>
+ #include <string.h>
+ #include "regexp.h"
diff --git a/print/lgrind/pkg-descr b/print/lgrind/pkg-descr
new file mode 100644
index 000000000000..39c438fa6c59
--- /dev/null
+++ b/print/lgrind/pkg-descr
@@ -0,0 +1,9 @@
+LGrind is a descendant of the Unix utility vgrind. It is
+used to produce a beautified version of your source code using LaTeX. Unlike
+other packages this is not pure TeX but an external preprocessor. You run e.g.
+ lgrind example.c > example.tex
+ latex example.tex
+to get a complete listing. Options for producing includable files and pro-
+cessing embedded listings in LaTeX texts are provided.
+
+WWW: http://www.ctan.org/pkg/lgrind
diff --git a/print/lgrind/pkg-plist b/print/lgrind/pkg-plist
new file mode 100644
index 000000000000..440ad0a42a9f
--- /dev/null
+++ b/print/lgrind/pkg-plist
@@ -0,0 +1,6 @@
+bin/lgrind
+share/texmf-dist/doc/latex/lgrind/lgrind.dvi
+share/texmf-dist/tex/latex/lgrind/lgrind.sty
+share/texmf-dist/tex/latex/lgrind/lgrindef
+man/man1/lgrind.1.gz
+man/man5/lgrindef.5.gz