aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-03-04 00:50:32 +0800
committermakc <makc@FreeBSD.org>2014-03-04 00:50:32 +0800
commitc05a76ed15368176b937f2b06dad88f13e12f4f0 (patch)
tree0facf8a13da71e87170cdfcf5902ed77d09cb72f /print
parent5e6b17ee28fc3150198fa33fda5c63d81fbc8872 (diff)
downloadfreebsd-ports-gnome-c05a76ed15368176b937f2b06dad88f13e12f4f0.tar.gz
freebsd-ports-gnome-c05a76ed15368176b937f2b06dad88f13e12f4f0.tar.zst
freebsd-ports-gnome-c05a76ed15368176b937f2b06dad88f13e12f4f0.zip
KDE/FreeBSD team is happy to present Qt 5 in ports!
Alberto Villa (avilla@) has done all the hard work to create Qt 5 ports. Trivial update from 5.2.0-beta1 to 5.2.1 by me. Special thanks for Adriaan de Groot <groot@kde.org> for his assistance for Qt-5.2.0 update. Approved by: portmgr (bapt) (for Mk/bsd.port.mk)
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/qt5-printsupport/Makefile57
-rw-r--r--print/qt5-printsupport/pkg-plist61
3 files changed, 119 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 6e7749399567..92fc2758eede 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -259,6 +259,7 @@
SUBDIR += py-trml2pdf
SUBDIR += qpdf
SUBDIR += qpdfview
+ SUBDIR += qt5-printsupport
SUBDIR += rlpr
SUBDIR += rprint
SUBDIR += rtf2latex
diff --git a/print/qt5-printsupport/Makefile b/print/qt5-printsupport/Makefile
new file mode 100644
index 000000000000..3bcde6896933
--- /dev/null
+++ b/print/qt5-printsupport/Makefile
@@ -0,0 +1,57 @@
+# $FreeBSD$
+
+PORTNAME= printsupport
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= print
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt print support module
+
+USE_QT5= core gui widgets qmake_build buildtools_build
+QT_DIST= base
+HAS_CONFIGURE= yes
+USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+OPTIONS_DEFINE= CUPS
+OPTIONS_DEFAULT=CUPS
+OPTIONS_SUB= yes
+
+CUPS_BUILD_DEPENDS= ${LOCALBASE}/include/cups/cups.h:${PORTSDIR}/print/cups-client
+CUPS_CONFIGURE_ON= -cups
+CUPS_CONFIGURE_OFF= -no-cups
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCUPS}
+QT_DEFINES+= CUPS
+QT_CONFIG+= cups
+.else
+QT_DEFINES+= -CUPS
+QT_CONFIG+= -cups
+.endif
+
+post-configure:
+.if ${PORT_OPTIONS:MCUPS}
+ @cd ${WRKSRC}/src/plugins/${PORTNAME}/cups && \
+ ${SETENV} ${QMAKE_ENV} ${WRKSRC}/bin/qmake ${QMAKE_ARGS}
+.endif
+
+post-build:
+.if ${PORT_OPTIONS:MCUPS}
+ @cd ${WRKSRC}/src/plugins/${PORTNAME}/cups && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
+ ${_MAKE_JOBS} ${MAKE_ARGS} ${ALL_TARGET}
+.endif
+
+post-install:
+.if ${PORT_OPTIONS:MCUPS}
+ @cd ${WRKSRC}/src/plugins/${PORTNAME}/cups && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
+ ${MAKE_ARGS} ${INSTALL_TARGET}
+.endif
+
+.include <bsd.port.mk>
diff --git a/print/qt5-printsupport/pkg-plist b/print/qt5-printsupport/pkg-plist
new file mode 100644
index 000000000000..1e470c410f64
--- /dev/null
+++ b/print/qt5-printsupport/pkg-plist
@@ -0,0 +1,61 @@
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/private/qabstractprintdialog_p.h
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/private/qcups_p.h
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/private/qcupsjobwidget_p.h
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/private/qpagesetupdialog_p.h
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/private/qpagesetupdialog_unix_p.h
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/private/qpaintengine_alpha_p.h
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/private/qpaintengine_preview_p.h
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/private/qprintengine_pdf_p.h
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/private/qprintengine_win_p.h
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/private/qprinter_p.h
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/private/qprinterinfo_p.h
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/qpa/qplatformprintersupport.h
+%%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/qpa/qplatformprintplugin.h
+%%QT_INCDIR%%/QtPrintSupport/QAbstractPrintDialog
+%%QT_INCDIR%%/QtPrintSupport/QPageSetupDialog
+%%QT_INCDIR%%/QtPrintSupport/QPrintDialog
+%%QT_INCDIR%%/QtPrintSupport/QPrintEngine
+%%QT_INCDIR%%/QtPrintSupport/QPrintPreviewDialog
+%%QT_INCDIR%%/QtPrintSupport/QPrintPreviewWidget
+%%QT_INCDIR%%/QtPrintSupport/QPrinter
+%%QT_INCDIR%%/QtPrintSupport/QPrinterInfo
+%%QT_INCDIR%%/QtPrintSupport/QtPrintSupport
+%%QT_INCDIR%%/QtPrintSupport/QtPrintSupportDepends
+%%QT_INCDIR%%/QtPrintSupport/QtPrintSupportVersion
+%%QT_INCDIR%%/QtPrintSupport/qabstractprintdialog.h
+%%QT_INCDIR%%/QtPrintSupport/qpagesetupdialog.h
+%%QT_INCDIR%%/QtPrintSupport/qprintdialog.h
+%%QT_INCDIR%%/QtPrintSupport/qprintengine.h
+%%QT_INCDIR%%/QtPrintSupport/qprinter.h
+%%QT_INCDIR%%/QtPrintSupport/qprinterinfo.h
+%%QT_INCDIR%%/QtPrintSupport/qprintpreviewdialog.h
+%%QT_INCDIR%%/QtPrintSupport/qprintpreviewwidget.h
+%%QT_INCDIR%%/QtPrintSupport/qtprintsupportglobal.h
+%%QT_INCDIR%%/QtPrintSupport/qtprintsupportversion.h
+%%QT_LIBDIR%%/cmake/Qt5PrintSupport/Qt5PrintSupportConfig.cmake
+%%QT_LIBDIR%%/cmake/Qt5PrintSupport/Qt5PrintSupportConfigVersion.cmake
+%%QT_LIBDIR%%/libQt5PrintSupport.la
+%%QT_LIBDIR%%/libQt5PrintSupport.prl
+%%QT_LIBDIR%%/libQt5PrintSupport.so
+%%QT_LIBDIR%%/libQt5PrintSupport.so.5
+%%QT_LIBDIR%%/libQt5PrintSupport.so.%%SHORTVER%%
+%%QT_LIBDIR%%/libQt5PrintSupport.so.%%FULLVER%%
+%%DEBUG%%%%QT_LIBDIR%%/libQt5PrintSupport.so.%%FULLVER%%.debug
+%%QT_MKSPECDIR%%/modules/qt_lib_printsupport.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_printsupport_private.pri
+%%CUPS%%%%QT_PLUGINDIR%%/printsupport/libcupsprintersupport.so
+%%CUPS%%%%DEBUG%%%%QT_PLUGINDIR%%/printsupport/libcupsprintersupport.so.debug
+libdata/pkgconfig/Qt5PrintSupport.pc
+%%CUPS%%@dirrm %%QT_PLUGINDIR%%/printsupport
+%%CUPS%%@dirrmtry %%QT_PLUGINDIR%%
+@dirrmtry %%QT_MKSPECDIR%%/modules
+@dirrmtry %%QT_MKSPECDIR%%
+@dirrmtry %%QT_ARCHDIR%%
+@dirrm %%QT_LIBDIR%%/cmake/Qt5PrintSupport
+@dirrmtry %%QT_LIBDIR%%/cmake
+@dirrm %%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/qpa
+@dirrm %%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport/private
+@dirrm %%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%/QtPrintSupport
+@dirrm %%QT_INCDIR%%/QtPrintSupport/%%FULLVER%%
+@dirrm %%QT_INCDIR%%/QtPrintSupport
+@dirrmtry %%QT_INCDIR%%