aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2006-02-09 21:09:27 +0800
committerlawrance <lawrance@FreeBSD.org>2006-02-09 21:09:27 +0800
commitcaadee686d4110e9350da5ab9486aa7ccf82e00f (patch)
tree5f982124c78ea4bcdf7578459268f4d46ae834f9 /print
parent9b439780ecaca67aa6b575c231dbe461eabd8f97 (diff)
downloadfreebsd-ports-gnome-caadee686d4110e9350da5ab9486aa7ccf82e00f.tar.gz
freebsd-ports-gnome-caadee686d4110e9350da5ab9486aa7ccf82e00f.tar.zst
freebsd-ports-gnome-caadee686d4110e9350da5ab9486aa7ccf82e00f.zip
Use bash rather than /bin/sh due to some linuxisms.
PR: ports/92945 Submitted by: Paul Chvostek <paul+ports@it.ca> (maintainer)
Diffstat (limited to 'print')
-rw-r--r--print/pdfjam/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/print/pdfjam/Makefile b/print/pdfjam/Makefile
index 456efb799263..d1ca9924d346 100644
--- a/print/pdfjam/Makefile
+++ b/print/pdfjam/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pdfjam
PORTVERSION= 1.20
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= http://www2.warwick.ac.uk/fac/sci/statistics/staff/academic/firth/software/pdfjam/ \
http://www.it.ca/~paul/src/
@@ -16,7 +17,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= paul+ports@it.ca
COMMENT= Shell scripts to manipulate PDF files
-RUN_DEPENDS= pdflatex:${PORTSDIR}/print/teTeX-base
+RUN_DEPENDS= pdflatex:${PORTSDIR}/print/teTeX-base \
+ bash:${PORTSDIR}/shells/bash
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -29,7 +31,7 @@ NO_BUILD= yes
post-patch:
@${LN} -s scripts ${WRKSRC}/bin
.for FILE in ${PLIST_FILES}
- @${SED} -i '' "1s:^#! /bin/sh:#!${SH}:;s:__LOCALBASE__:${LOCALBASE}:" ${WRKSRC}/${FILE}
+ @${SED} -i '' "1s:^#! /bin/sh:#!${LOCALBASE}/bin/bash:;s:__LOCALBASE__:${LOCALBASE}:" ${WRKSRC}/${FILE}
.endfor
do-install: