aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-11-23 04:18:37 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-11-23 04:18:37 +0800
commitcc8a667aa283dbd1c377aa55dd4b47568cebc6b9 (patch)
tree61cb3664013fb792e76869e17b47783aadc54052 /print
parent9ea8c5a60afa67ef2f40c0e73594522c3aec51a6 (diff)
downloadfreebsd-ports-gnome-cc8a667aa283dbd1c377aa55dd4b47568cebc6b9.tar.gz
freebsd-ports-gnome-cc8a667aa283dbd1c377aa55dd4b47568cebc6b9.tar.zst
freebsd-ports-gnome-cc8a667aa283dbd1c377aa55dd4b47568cebc6b9.zip
pyqt: Change install directories for Python flavor support
* PyQt could not be installed for multiple Python versions at the same time, as there were conflicting files. This patch creates Python-version versioned directories for all these, and further installs binaries with a version number. * Note, there might be some hickups for software that depends on on of the .so's provided by PyQt5, which might not be found anymore autmotically, and maybe need some LD-flaggery. * Update PyQt5 to 5.10.1 * Mark www/py-qt5-webengine broken. It is unforuntately no longer compatible with the old qt5-webengine-5.9.4 we ship. PR: 232745 Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D8714
Diffstat (limited to 'print')
-rw-r--r--print/hplip/Makefile1
-rw-r--r--print/py-qt5-printsupport/Makefile5
-rw-r--r--print/py-qt5-printsupport/pkg-plist2
3 files changed, 4 insertions, 4 deletions
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index dff67cd7ef0a..ad2fd2545be8 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -3,6 +3,7 @@
PORTNAME= hplip
PORTVERSION= 3.17.11
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= SF
diff --git a/print/py-qt5-printsupport/Makefile b/print/py-qt5-printsupport/Makefile
index 222194250914..6d25ffe2db22 100644
--- a/print/py-qt5-printsupport/Makefile
+++ b/print/py-qt5-printsupport/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= printsupport
-PORTREVISION= 5
CATEGORIES= print python
MAINTAINER= kde@FreeBSD.org
@@ -13,7 +12,7 @@ PYQT_DIST= yes
USES= python pyqt:5 qt:5
USE_GL= gl
USE_PYQT= sip_build core_run widgets_run
-USE_PYTHON= flavors
+USE_PYTHON= concurrent flavors py3kplist
USE_QT= core gui printsupport widgets qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -21,7 +20,7 @@ OPTIONS_DEFAULT=API
OPTIONS_SUB= yes
API_DESC= Install QtPrintsupport API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace
diff --git a/print/py-qt5-printsupport/pkg-plist b/print/py-qt5-printsupport/pkg-plist
index 5c9854802759..5a26574cb924 100644
--- a/print/py-qt5-printsupport/pkg-plist
+++ b/print/py-qt5-printsupport/pkg-plist
@@ -10,4 +10,4 @@
%%PYQT_SIPDIR%%/QtPrintSupport/qprintpreviewdialog.sip
%%PYQT_SIPDIR%%/QtPrintSupport/qprintpreviewwidget.sip
%%PYQT_SIPDIR%%/QtPrintSupport/qpyprintsupport_qlist.sip
-%%API%%share/qt5/qsci/api/python/QtPrintSupport.api
+%%API%%%%PYQT_APIDIR%%/api/python/QtPrintSupport.api