aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-31 04:22:48 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-31 04:22:48 +0800
commitce9f0c42ec334e10febaab6b91e808db9ed78148 (patch)
tree0bb43e73d1d2293e8ec2903aabf256e4e6dc0855 /print
parentf2c644ac3f3c4c396431b212170f48fea1908c01 (diff)
downloadfreebsd-ports-gnome-ce9f0c42ec334e10febaab6b91e808db9ed78148.tar.gz
freebsd-ports-gnome-ce9f0c42ec334e10febaab6b91e808db9ed78148.tar.zst
freebsd-ports-gnome-ce9f0c42ec334e10febaab6b91e808db9ed78148.zip
- Resurrect pring/cups-smb-backend. It was depended due to "No more
public distfiles", however it never had nor needed distfiles to begin with. - Stagify CUPS smb backend allows *nix users to print to Windows-attached printers via smbspool program, which comes with Samba. WWW: http://www.cups.org/articles.php?L294 Pointyhat to: bapt
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/cups-smb-backend/Makefile26
-rw-r--r--print/cups-smb-backend/files/pkg-message.in17
-rw-r--r--print/cups-smb-backend/pkg-descr5
4 files changed, 49 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index cfd7400ab1ac..6c7eb2cbd963 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -39,6 +39,7 @@
SUBDIR += cups-pk-helper
SUBDIR += cups-pstoraster
SUBDIR += cups-samba
+ SUBDIR += cups-smb-backend
SUBDIR += deforaos-pdfviewer
SUBDIR += detex
SUBDIR += dk-acroread8
diff --git a/print/cups-smb-backend/Makefile b/print/cups-smb-backend/Makefile
new file mode 100644
index 000000000000..563a937275ff
--- /dev/null
+++ b/print/cups-smb-backend/Makefile
@@ -0,0 +1,26 @@
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cups-smb-backend
+PORTVERSION= 1.0
+PORTREVISION= 6
+CATEGORIES= print
+MASTER_SITES= # empty
+DISTFILES= # empty
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= CUPS backend for printing to Windows servers
+
+RUN_DEPENDS= smbspool:${PORTSDIR}/net/${SAMBA_PORT} \
+ ${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base
+
+NO_BUILD= yes
+PLIST_FILES= libexec/cups/backend/smb
+SAMBA_PORT?= samba36
+SUB_FILES= pkg-message
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/cups/backend
+ ${LN} -fs ${PREFIX}/bin/smbspool ${STAGEDIR}${PREFIX}/libexec/cups/backend/smb
+
+.include <bsd.port.mk>
diff --git a/print/cups-smb-backend/files/pkg-message.in b/print/cups-smb-backend/files/pkg-message.in
new file mode 100644
index 000000000000..02f336ddda79
--- /dev/null
+++ b/print/cups-smb-backend/files/pkg-message.in
@@ -0,0 +1,17 @@
+CUPS smb backend is now installed.
+
+Please configure your samba environment if
+you haven't already done so. To do so edit
+
+%%PREFIX%%/etc/smb.conf
+
+You can then add a new printer to CUPS.
+smbspool(8) manpage describes device URI
+format. In most cases (latest samba 2.x
+and samba 3.x), it's something like this:
+
+smb://username:password@server/printer
+smb://username:password@workgroup/server/printer
+
+But a CUPS article describes another syntax,
+so beware.
diff --git a/print/cups-smb-backend/pkg-descr b/print/cups-smb-backend/pkg-descr
new file mode 100644
index 000000000000..e86a36c61b8a
--- /dev/null
+++ b/print/cups-smb-backend/pkg-descr
@@ -0,0 +1,5 @@
+CUPS smb backend allows *nix users to print
+to Windows-attached printers via smbspool
+program, which comes with Samba.
+
+WWW: http://www.cups.org/articles.php?L294