aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-07-19 02:43:55 +0800
committerhrs <hrs@FreeBSD.org>2015-07-19 02:43:55 +0800
commitd4910e9fa8be3bdf5fd44ce203f767afa35065ed (patch)
treec1a638717bc4ff5763797968bd4055ba32051162 /print
parentd3298d0704fa249473e09437ceb482caaa065393 (diff)
downloadfreebsd-ports-gnome-d4910e9fa8be3bdf5fd44ce203f767afa35065ed.tar.gz
freebsd-ports-gnome-d4910e9fa8be3bdf5fd44ce203f767afa35065ed.tar.zst
freebsd-ports-gnome-d4910e9fa8be3bdf5fd44ce203f767afa35065ed.zip
- Fix build breakage due to _XOPEN_VERSION macro.
- Fix iconv dependency. - Remove unnecessary lines for libjasper.
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript9-agpl/Makefile8
-rw-r--r--print/ghostscript9-agpl/files/patch-trio-triodef.h26
2 files changed, 30 insertions, 4 deletions
diff --git a/print/ghostscript9-agpl/Makefile b/print/ghostscript9-agpl/Makefile
index 89019bf52815..df5e01c46a64 100644
--- a/print/ghostscript9-agpl/Makefile
+++ b/print/ghostscript9-agpl/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ghostscript
PORTVERSION= 9.16
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
@@ -32,7 +33,7 @@ CONFLICTS_INSTALL= \
ghostscript[789]-[0-9]* \
ghostscript[789]-nox11-[0-9]*
-USES= gmake jpeg pkgconfig:build autoreconf tar:bzip2
+USES= gmake jpeg pkgconfig:build autoreconf tar:bzip2 iconv
WANT_GNOME= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -44,14 +45,13 @@ CONFIGURE_ENV= ${MAKE_ENV}
CONFIGURE_ARGS= --disable-compile-inits \
--enable-contrib \
--enable-dynamic \
+ --with-libiconv=native \
--with-system-libtiff \
--with-ijs \
--with-libidn \
- --without-jasper \
--with-libpaper \
--with-drivers=""
CPPFLAGS+= -DUPD_SIGNAL=0 -I. \
- -I${WRKSRC}/lcms2/include \
-I${LOCALBASE}/include/libpng \
-I${WRKSRC}/openjpeg/src/lib/openjp2 \
-I${LOCALBASE}/include
@@ -71,7 +71,7 @@ OPTIONS_SUB= yes
FONTCONFIG_DESC=Enable fontconfig support
NO_OPTIONS_SORT=yes
-EXCLUDE_DIRS= freetype jbig2dec jpeg expat jasper lcms libpng tiff zlib
+EXCLUDE_DIRS= freetype jbig2dec jpeg expat lcms2 libpng tiff zlib
.include "Makefile.drivers"
.include <bsd.port.options.mk>
diff --git a/print/ghostscript9-agpl/files/patch-trio-triodef.h b/print/ghostscript9-agpl/files/patch-trio-triodef.h
new file mode 100644
index 000000000000..8428c0fedc98
--- /dev/null
+++ b/print/ghostscript9-agpl/files/patch-trio-triodef.h
@@ -0,0 +1,26 @@
+--- trio/triodef.h.orig 2015-07-19 03:20:32.007345000 +0900
++++ trio/triodef.h 2015-07-19 03:27:30.381863000 +0900
+@@ -185,12 +185,13 @@
+ # endif
+ #endif
+
+-#if (_XOPEN_VERSION - 0 >= 3) || defined(_XOPEN_XPG3)
++#if (defined(_XOPEN_VERSION) && (_XOPEN_VERSION - 0 >= 3)) || defined(_XOPEN_XPG3)
+ # define PREDEF_STANDARD_XPG3
+ #endif
+-#if (_XOPEN_VERSION - 0 >= 4) || defined(_XOPEN_XPG4)
++#if (defined(_XOPEN_VERSION) && (_XOPEN_VERSION - 0 >= 4)) || defined(_XOPEN_XPG4)
+ # define PREDEF_STANDARD_XPG4
+ #endif
++#if defined(_XOPEN_VERSION)
+ #if (_XOPEN_VERSION - 0 > 4) \
+ || (defined(_XOPEN_UNIX) && (_XOPEN_VERSION - 0 == 4))
+ # define PREDEF_STANDARD_UNIX95
+@@ -201,6 +202,7 @@
+ #if (_XOPEN_VERSION - 0 >= 600)
+ # define PREDEF_STANDARD_UNIX03
+ #endif
++#endif
+
+ /*************************************************************************
+ * Generic defines