aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-05-14 19:43:23 +0800
committerpav <pav@FreeBSD.org>2010-05-14 19:43:23 +0800
commite38d3b9af7754363ed4955a57a7812459ef91d60 (patch)
treeb36386a9a5045ad8e7684614fad2f88ec5f7b880 /print
parent3857bf95f623d740598a7604e663da963c31c4b7 (diff)
downloadfreebsd-ports-gnome-e38d3b9af7754363ed4955a57a7812459ef91d60.tar.gz
freebsd-ports-gnome-e38d3b9af7754363ed4955a57a7812459ef91d60.tar.zst
freebsd-ports-gnome-e38d3b9af7754363ed4955a57a7812459ef91d60.zip
- Fix issue regarding net-snmp
- Fix issue with fax when disabling dbus - NOPORTDOCS cleanliness PR: ports/146535 Submitted by: Chris Petrik <chris@officialunix.com> (maintainer)
Diffstat (limited to 'print')
-rw-r--r--print/hplip3/Makefile31
-rw-r--r--print/hplip3/pkg-plist42
2 files changed, 44 insertions, 29 deletions
diff --git a/print/hplip3/Makefile b/print/hplip3/Makefile
index b441feba4ccc..7a204b365267 100644
--- a/print/hplip3/Makefile
+++ b/print/hplip3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hplip
PORTVERSION= 3.10.2
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= SF
@@ -15,9 +16,7 @@ COMMENT= Drivers and utilities for HP Printers and All-in-One devices
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
sane.1:${PORTSDIR}/graphics/sane-backends \
- cups.2:${PORTSDIR}/print/cups-base \
- dbus-1.3:${PORTSDIR}/devel/dbus \
- netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
+ cups.2:${PORTSDIR}/print/cups-base
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab2 \
espgs:${PORTSDIR}/print/cups-pstoraster \
foomatic-rip:${PORTSDIR}/print/foomatic-filters \
@@ -29,6 +28,8 @@ CONFLICTS= hpijs-[0-9]* hplip-2*
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking \
--disable-pp-build \
+ --disable-dbus-build \
+ --disable-fax-build \
--enable-foomatic-ppd-install \
--enable-foomatic-rip-hplip-install \
--enable-hpijs-install \
@@ -37,7 +38,8 @@ CONFIGURE_ARGS= --disable-dependency-tracking \
--with-cupsfilterdir=${LOCALBASE}/libexec/cups/filter \
--with-drvdir=${LOCALBASE}/libexec/cups/driver \
--with-hpppddir=${LOCALBASE}/share/ppd/HP \
- --with-mimedir=${LOCALBASE}/etc/cups
+ --with-mimedir=${LOCALBASE}/etc/cups \
+ --with-docdir=${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
USE_LDCONFIG= yes
USE_GHOSTSCRIPT_RUN= yes
@@ -53,10 +55,10 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lcompat
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-OPTIONS= GUI "build with Python QT" on \
- DBUS "dbus support" on \
- XSANE "build xsane scanner app" on
-
+OPTIONS= GUI "build with Python QT" off \
+ DBUS "dbus support" off \
+ XSANE "build xsane scanner app" off \
+ NOSNMP "Build without snmp" on
.include <bsd.port.options.mk>
.if ${OSVERSION} < 800069
@@ -74,12 +76,25 @@ LIB_DEPENDS+= pyglib-2.0:${PORTSDIR}/devel/py-gobject
.if !defined(WITHOUT_DBUS)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dbus/_dbus.py:${PORTSDIR}/devel/py-dbus \
${PYTHON_SITELIBDIR}/dbus/mainloop/qt.so:${PORTSDIR}/devel/py-qt4-dbus
+LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
+CONFIGURE_ARGS+= --enable-dbus-build \
+ --enable-fax-build
+PLIST_SUB+= FAX=""
+.else
+PLIST_SUB+= FAX="@comment "
.endif
.if !defined(WITHOUT_XSANE)
RUN_DEPENDS+= xsane:${PORTSDIR}/graphics/xsane
.endif
+.if !defined(WITHOUT_NOSNMP)
+LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
+CONFIGURE_ARGS+= --enable-network-build
+.else
+CONFIGURE_ARGS+= --disable-network-build
+.endif
+
.if defined(NOPORTDOCS)
CONFIGURE_ARGS+= --enable-doc-build=no
.endif
diff --git a/print/hplip3/pkg-plist b/print/hplip3/pkg-plist
index e9a8510b98e3..8a585c43ec56 100644
--- a/print/hplip3/pkg-plist
+++ b/print/hplip3/pkg-plist
@@ -34,8 +34,8 @@ sbin/hpssd
etc/hp/hplip.conf.sample
@exec if [ ! -f %B/hplip.conf ]; then cp -p %D/%F %B/hplip.conf; fi
etc/xdg/autostart/hplip-systray.desktop
-etc/cups/pstotiff.convs
-etc/cups/pstotiff.types
+%%FAX%%etc/cups/pstotiff.convs
+%%FAX%%etc/cups/pstotiff.types
lib/libhpip.la
lib/libhpip.so
lib/libhpip.so.0
@@ -55,11 +55,11 @@ lib/sane/libsane-hpaio.so
lib/sane/libsane-hpaio.so.1
libexec/cups/filter/hpcac
libexec/cups/filter/hpcups
-libexec/cups/filter/hpcupsfax
+%%FAX%%libexec/cups/filter/hpcupsfax
libexec/cups/filter/hplipjs
libexec/cups/filter/pstotiff
libexec/cups/backend/hp
-libexec/cups/backend/hpfax
+%%FAX%%libexec/cups/backend/hpfax
libexec/cups/driver/hpcups.drv
libexec/cups/filter/foomatic-rip-hplip
%%PORTDOCS%%%%DOCSDIR%%/COPYING
@@ -478,16 +478,16 @@ libexec/cups/filter/foomatic-rip-hplip
%%DATADIR%%/data/ps/testpage.ps.gz
%%DATADIR%%/devicesettings.py
%%DATADIR%%/fab.py
-%%DATADIR%%/fax/__init__.py
-%%DATADIR%%/fax/coverpages.py
-%%DATADIR%%/fax/fax.py
-%%DATADIR%%/fax/faxdevice.py
-%%DATADIR%%/fax/pmlfax.py
-%%DATADIR%%/fax/soapfax.py
-%%DATADIR%%/fax/marvellfax.py
-%%DATADIR%%/fax/pstotiff
-%%DATADIR%%/fax/pstotiff.convs
-%%DATADIR%%/fax/pstotiff.types
+%%FAX%%%%DATADIR%%/fax/__init__.py
+%%FAX%%%%DATADIR%%/fax/coverpages.py
+%%FAX%%%%DATADIR%%/fax/fax.py
+%%FAX%%%%DATADIR%%/fax/faxdevice.py
+%%FAX%%%%DATADIR%%/fax/pmlfax.py
+%%FAX%%%%DATADIR%%/fax/soapfax.py
+%%FAX%%%%DATADIR%%/fax/marvellfax.py
+%%FAX%%%%DATADIR%%/fax/pstotiff
+%%FAX%%%%DATADIR%%/fax/pstotiff.convs
+%%FAX%%%%DATADIR%%/fax/pstotiff.types
%%DATADIR%%/faxsetup.py
%%DATADIR%%/firmware.py
%%DATADIR%%/hpdio.py
@@ -587,8 +587,8 @@ libexec/cups/filter/foomatic-rip-hplip
%%DATADIR%%/ui4/wifisetupdialog_base.py
%%DATADIR%%/unload.py
%%DATADIR%%/wificonfig.py
-share/ppd/HP/HP-Fax-hpcups.ppd.gz
-share/ppd/HP/HP-Fax2-hpcups.ppd.gz
+%%FAX%%share/ppd/HP/HP-Fax-hpcups.ppd.gz
+%%FAX%%share/ppd/HP/HP-Fax2-hpcups.ppd.gz
share/ppd/HP/hp-2000c-hpijs.ppd.gz
share/ppd/HP/hp-2500c-hpijs.ppd.gz
share/ppd/HP/hp-910-hpijs.ppd.gz
@@ -1346,8 +1346,8 @@ share/ppd/HP/hp-psc_920-hpijs.ppd.gz
share/ppd/HP/hp-psc_950-hpijs.ppd.gz
share/ppd/HP/hp-psc_950vr-hpijs.ppd.gz
share/ppd/HP/hp-psc_950xi-hpijs.ppd.gz
-share/ppd/HP/HP-Fax-hpijs.ppd.gz
-share/ppd/HP/HP-Fax2-hpijs.ppd.gz
+%%FAX%%share/ppd/HP/HP-Fax-hpijs.ppd.gz
+%%FAX%%share/ppd/HP/HP-Fax2-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_p3010_series-ps.ppd.gz
share/ppd/HP/hp-laserjet_p3010_series-hpijs-pcl3.ppd.gz
share/ppd/HP/hp-officejet_7000_e809a-hpijs.ppd.gz
@@ -1358,8 +1358,8 @@ share/ppd/HP/hp-photosmart_c4700_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_670c-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_d1600_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_d5500_series-hpijs.ppd.gz
-share/ppd/HP/HP-Fax3-hpcups.ppd.gz
-share/ppd/HP/HP-Fax3-hpijs.ppd.gz
+%%FAX%%share/ppd/HP/HP-Fax3-hpcups.ppd.gz
+%%FAX%%share/ppd/HP/HP-Fax3-hpijs.ppd.gz
share/ppd/HP/hp-color_laserjet_cp5225-ps.ppd.gz
share/ppd/HP/hp-color_laserjet_cm6040_mfp-ps.ppd.gz
share/ppd/HP/hp-color_laserjet_cp5225n-ps.ppd.gz
@@ -1394,7 +1394,7 @@ share/applications/hplip.desktop
@dirrm %%DATADIR%%/prnt
@dirrm %%DATADIR%%/pcard
@dirrm %%DATADIR%%/installer
-@dirrm %%DATADIR%%/fax
+%%FAX%%@dirrm %%DATADIR%%/fax
@dirrm %%DATADIR%%/data/ps
@dirrm %%DATADIR%%/data/pcl
@dirrm %%DATADIR%%/data/models