aboutsummaryrefslogtreecommitdiffstats
path: root/russian/prawda
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2013-09-12 23:12:49 +0800
committernovel <novel@FreeBSD.org>2013-09-12 23:12:49 +0800
commit863e0036a81b76091d5992e7edb2d27f9e067a12 (patch)
tree5ce55c29175b60d55490b221b7147c6c374f2577 /russian/prawda
parent45613e4294a836c0cff9442f33a459eaedbeeeb3 (diff)
downloadfreebsd-ports-gnome-863e0036a81b76091d5992e7edb2d27f9e067a12.tar.gz
freebsd-ports-gnome-863e0036a81b76091d5992e7edb2d27f9e067a12.tar.zst
freebsd-ports-gnome-863e0036a81b76091d5992e7edb2d27f9e067a12.zip
- Fix build with clang [1]
- Improve CXX respect (some makefiles had g++ hardcoded before) - Convert to new header format - Drop maintainership Reported by: pkg-fallout [1]
Diffstat (limited to 'russian/prawda')
-rw-r--r--russian/prawda/Makefile9
-rw-r--r--russian/prawda/files/patch-src-face-main.cpp11
2 files changed, 14 insertions, 6 deletions
diff --git a/russian/prawda/Makefile b/russian/prawda/Makefile
index 723d01b94742..9e2d45bf0a24 100644
--- a/russian/prawda/Makefile
+++ b/russian/prawda/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: prawda
-# Date created: 2004-07-28
-# Whom: Roman Bogorodskiy <bogordskiy@inbox.ru>
-#
# $FreeBSD$
-#
PORTNAME= prawda
PORTVERSION= 0.3.0
@@ -11,7 +6,7 @@ PORTREVISION= 4
CATEGORIES= russian
MASTER_SITES= http://www.prawda.newmail.ru/
-MAINTAINER= novel@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= English-Russian translator
USE_BZIP2= yes
@@ -22,6 +17,8 @@ CXXFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e "s|ulong|unsigned long|g;;s|malloc.h|stdlib.h|g" ${WRKSRC}/src/face/video_x.cpp
@${REINPLACE_CMD} -e "s|g++|${CXX} ${CXXFLAGS}|g" ${WRKSRC}/src/bin/makefile.exe
+ @${FIND} ${WRKSRC} -name makefile | ${XARGS} \
+ ${REINPLACE_CMD} -e "s|g++|${CXX} ${CXXFLAGS}|g"
@${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" ${WRKSRC}/bin/makefile ${WRKSRC}/src/face/main.cpp
do-build:
diff --git a/russian/prawda/files/patch-src-face-main.cpp b/russian/prawda/files/patch-src-face-main.cpp
new file mode 100644
index 000000000000..3c514660b064
--- /dev/null
+++ b/russian/prawda/files/patch-src-face-main.cpp
@@ -0,0 +1,11 @@
+--- src/face/main.cpp.orig 2013-09-12 18:53:29.000000000 +0400
++++ src/face/main.cpp 2013-09-12 18:53:35.000000000 +0400
+@@ -223,7 +223,7 @@
+ /***************************************************************************/
+
+ /***************************************************************************/
+-int main( short argc, char *argv[] )
++int main( int argc, char *argv[] )
+ { char r,r1 ;
+ char Str[200]="" ;
+ short sx=80,sy=50 ;