aboutsummaryrefslogtreecommitdiffstats
path: root/science/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2016-11-12 00:49:21 +0800
committerthierry <thierry@FreeBSD.org>2016-11-12 00:49:21 +0800
commit27753fb2974f4b2f8e7b40af2961f0d92f9a52af (patch)
tree8bf0cb34490fc533cadbf794ac1e272aa9eea4db /science/Makefile
parentb040ee8b7a40a55dc6c538cd2f0c1657fab65bac (diff)
downloadfreebsd-ports-gnome-27753fb2974f4b2f8e7b40af2961f0d92f9a52af.tar.gz
freebsd-ports-gnome-27753fb2974f4b2f8e7b40af2961f0d92f9a52af.tar.zst
freebsd-ports-gnome-27753fb2974f4b2f8e7b40af2961f0d92f9a52af.zip
`MFront` is a code generator which translates a set of closely related
domain specific languages into plain C++ on top of the `TFEL` library. Those languages covers three kind of material knowledge: - material properties (for instance the Young modulus, the thermal conductivity, etc.) - mechanical behaviours. Numerical performances of generated mechanical behaviours was given a particular attention. Various benchmarks shows that `MFront` implementations are competitive with native implementations available in the `Cast3M`, `Code-Aster` and `Cyrano3` solvers. - simple point-wise models, such as material swelling used in fuel performance codes. `MFront` comes with an handy easy-to-use tool called `MTest` that can test the local behaviour of a material, by imposing independent constraints on each component of the strain or the stress. This tool has been much faster (from ten to several hundred times depending on the test case) than using a full-fledged finite element solver. WWW: http://tfel.sourceforge.net/ PR: 212375 Submitted by: Pedro F. Giffuni
Diffstat (limited to 'science/Makefile')
-rw-r--r--science/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 18783a7a191c..5d02ee40265e 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -179,6 +179,7 @@
SUBDIR += step
SUBDIR += svmlight
SUBDIR += szip
+ SUBDIR += tfel
SUBDIR += udunits
SUBDIR += v_sim
SUBDIR += veusz