aboutsummaryrefslogtreecommitdiffstats
path: root/science/cdo
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-11 16:41:34 +0800
committerpav <pav@FreeBSD.org>2006-06-11 16:41:34 +0800
commite2211023e0e9a9e6220c1d5a57d32970680868cf (patch)
treef7730ce8a6e714bb5c70ac41c0fb5a8c5be6b10f /science/cdo
parent4c7a4d5f0055619e5b649d20fdf30faac3e3ed56 (diff)
downloadfreebsd-ports-gnome-e2211023e0e9a9e6220c1d5a57d32970680868cf.tar.gz
freebsd-ports-gnome-e2211023e0e9a9e6220c1d5a57d32970680868cf.tar.zst
freebsd-ports-gnome-e2211023e0e9a9e6220c1d5a57d32970680868cf.zip
CDO is a collection of command line Operators to manipulate and analyse Climate
model Data. Supported file formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 250 operators available. The following table gives a short overview about the main categories. * File information (info, sinfo, diff, ...) * File operations (copy, cat, merge, split*, ...) * Selection (selcode, selvar, sellevel, seltimestep, ...) * Missing values (setctomiss, setmisstoc, setrtomiss) * Arithmetic (add, sub, mul, div, ...) * Mathematical functions (sqrt, exp, log, sin, cos, ...) * Comparision (eq, ne, le, lt, ge, gt, ...) * Conditions (ifthen, ifnotthen, ifthenc, ifnotthenc) * Field statistic (fldsum, fldavg, fldstd, fldmin, fldmax, ...) * Vertical statistic (vertsum, vertavg, vertstd, vertmin, ...) * Time range statistic (timavg, yearavg, monavg, dayavg, ...) * Ensemble statistic (enssum, ensavg, ensstd, ensmin, ...) * Regression (detrend) * Field interpolation (remapbil, remapcon, remapdis, ...) * Vertical interpolation (ml2pl, ml2hl) * Time interpolation (inttime, intyear) WWW: http://www.mpimet.mpg.de/fileadmin/software/cdo/ PR: ports/98099 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
Diffstat (limited to 'science/cdo')
-rw-r--r--science/cdo/Makefile40
-rw-r--r--science/cdo/distinfo3
-rw-r--r--science/cdo/files/patch-src__cdilib.c10
-rw-r--r--science/cdo/pkg-descr23
4 files changed, 76 insertions, 0 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
new file mode 100644
index 000000000000..2b66d9423ccc
--- /dev/null
+++ b/science/cdo/Makefile
@@ -0,0 +1,40 @@
+# ex:ts=8
+# New ports collection makefile for: CDO
+# Date created: 29 May 2006
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cdo
+PORTVERSION= 0.9.13
+CATEGORIES= science
+MASTER_SITES= http://www.mpimet.mpg.de/fileadmin/software/cdo/ \
+ http://sunpoet.net/distfiles/
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= Climate Data Operators
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --program-transform-name=""
+CONFIGURE_ENV= CC="${CC}" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+PLIST_FILES= bin/cdo
+
+OPTIONS= HDF5 "HDF5 support" off \
+ NETCDF "NETCDF support" off
+
+.if defined(WITH_HDF5)
+CONFIGURE_ARGS+= --with-hdf5=${LOCALBASE}/include
+LIB_DEPENDS+= hdf5.0:${PORTSDIR}/science/hdf5
+.endif
+
+.if defined(WITH_NETCDF)
+CONFIGURE_ARGS+= --with-netcdf=${LOCALBASE}/include
+LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
+.endif
+
+.include <bsd.port.mk>
diff --git a/science/cdo/distinfo b/science/cdo/distinfo
new file mode 100644
index 000000000000..f182a2f9373a
--- /dev/null
+++ b/science/cdo/distinfo
@@ -0,0 +1,3 @@
+MD5 (cdo-0.9.13.tar.gz) = dc93ea5130c02fa6c1d56c0296df623b
+SHA256 (cdo-0.9.13.tar.gz) = d78d24761c451f6aaae0e631b4dec8c341acb593806a0f95d0dd4ac634ece87a
+SIZE (cdo-0.9.13.tar.gz) = 594776
diff --git a/science/cdo/files/patch-src__cdilib.c b/science/cdo/files/patch-src__cdilib.c
new file mode 100644
index 000000000000..e252ab4c158e
--- /dev/null
+++ b/science/cdo/files/patch-src__cdilib.c
@@ -0,0 +1,10 @@
+--- src/cdilib.c.orig Mon Mar 6 17:08:36 2006
++++ src/cdilib.c Mon May 29 22:28:01 2006
+@@ -3948,7 +3948,6 @@
+
+ #if ! defined (HAVE_MALLOC_H)
+ # if defined (__sun) || defined (__i386) || defined (__ia64) || defined (SX)
+-# define HAVE_MALLOC_H
+ # endif
+ #endif
+
diff --git a/science/cdo/pkg-descr b/science/cdo/pkg-descr
new file mode 100644
index 000000000000..ae8e486f05d2
--- /dev/null
+++ b/science/cdo/pkg-descr
@@ -0,0 +1,23 @@
+CDO is a collection of command line Operators to manipulate and analyse Climate
+model Data. Supported file formats are GRIB, netCDF, SERVICE, EXTRA and IEG.
+There are more than 250 operators available. The following table gives a short
+overview about the main categories.
+
+* File information (info, sinfo, diff, ...)
+* File operations (copy, cat, merge, split*, ...)
+* Selection (selcode, selvar, sellevel, seltimestep, ...)
+* Missing values (setctomiss, setmisstoc, setrtomiss)
+* Arithmetic (add, sub, mul, div, ...)
+* Mathematical functions (sqrt, exp, log, sin, cos, ...)
+* Comparision (eq, ne, le, lt, ge, gt, ...)
+* Conditions (ifthen, ifnotthen, ifthenc, ifnotthenc)
+* Field statistic (fldsum, fldavg, fldstd, fldmin, fldmax, ...)
+* Vertical statistic (vertsum, vertavg, vertstd, vertmin, ...)
+* Time range statistic (timavg, yearavg, monavg, dayavg, ...)
+* Ensemble statistic (enssum, ensavg, ensstd, ensmin, ...)
+* Regression (detrend)
+* Field interpolation (remapbil, remapcon, remapdis, ...)
+* Vertical interpolation (ml2pl, ml2hl)
+* Time interpolation (inttime, intyear)
+
+WWW: http://www.mpimet.mpg.de/fileadmin/software/cdo/