aboutsummaryrefslogtreecommitdiffstats
path: root/science/gromacs
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2009-05-31 00:17:14 +0800
committerrafan <rafan@FreeBSD.org>2009-05-31 00:17:14 +0800
commit39feb7b241a1a53d52b807e547b385a136784dd7 (patch)
tree0b1b99534ccbfb5e51cd6387d61a33141f09ccb6 /science/gromacs
parent0bde605bcfdb5e5abf43a219face700995f6eb1c (diff)
downloadfreebsd-ports-gnome-39feb7b241a1a53d52b807e547b385a136784dd7.tar.gz
freebsd-ports-gnome-39feb7b241a1a53d52b807e547b385a136784dd7.tar.zst
freebsd-ports-gnome-39feb7b241a1a53d52b807e547b385a136784dd7.zip
- Fix build on sparc64 by files/patch-include__gmx_cyclecounter.h
- Fix WITH_MPICH - Use LOCALBASE for reference to bits installed by others - Pass maintainership to the submitter - Pet portlint(1): IGNORE PR: ports/133242 Submitted by: Florian Smeets <flo at kasimir.com> Approved by: Stephen Montgomery-Smith <stephen at math.missouri.edu> (maintainer)
Diffstat (limited to 'science/gromacs')
-rw-r--r--science/gromacs/Makefile28
-rw-r--r--science/gromacs/files/patch-include__gmx_cyclecounter.h11
2 files changed, 23 insertions, 16 deletions
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index 326c53c28a9e..918c5c8c0ed4 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -11,7 +11,7 @@ PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
-MAINTAINER= stephen@missouri.edu
+MAINTAINER= flo@kasimir.com
COMMENT= Compute molecular dynamics
USE_GNOME= libxml2
@@ -28,21 +28,17 @@ OPTIONS= FFTW3 "Use FFT routines from math/fftw3" on \
GSL "Enable extra analysis using math/gsl" on \
FLOAT "Use single instead of double precision" off \
X11 "Build and install X11 programs" on \
- MPICH "Enable MPI support using net/mpich" off \
+ MPICH "Enable MPI support using net/mpich2" off \
OMPI "Enable MPI support using net/openmpi" off
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
.if !defined(WITHOUT_FFTW3) && defined(WITH_FFTW2)
-IGNORE= Cannot build with FFTW3 and FFTW2. Run 'make config' again and choose only one of them.
+IGNORE= cannot build with FFTW3 and FFTW2. Run 'make config' again and choose only one of them
.endif
.if defined(WITH_MPICH) && defined(WITH_OMPI)
-IGNORE= Cannot build with MPICH and OpenMPI support. Run 'make config' again and choose only one of them.
+IGNORE= cannot build with MPICH and OpenMPI support. Run 'make config' again and choose only one of them
.endif
.if !defined(WITHOUT_FFTW3)
@@ -90,15 +86,15 @@ PLIST_SUB+= SUFFIX_D=_d SUFFIX_DOUBLE=_double
.if defined(WITH_MPICH) || defined(WITH_OMPI)
CONFIGURE_ARGS+= --enable-mpi
-. if defined(WITH_MPICH)
-CONFIGURE_ENV+= MPICC=${PREFIX}/mpich/bin/mpicc
-BUILD_DEPENDS+= ${PREFIX}/mpich/bin/mpicc:${PORTSDIR}/net/mpich
-RUN_DEPENDS+= ${PREFIX}/mpich/bin/mpicc:${PORTSDIR}/net/mpich
-. else
+.if defined(WITH_MPICH)
+CONFIGURE_ENV+= MPICC=${PREFIX}/mpich2/bin/mpicc
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+.elif defined(WITH_OMPI)
CONFIGURE_ENV+= MPICC=${PREFIX}/mpi/openmpi/bin/mpicc
-BUILD_DEPENDS+= ${PREFIX}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
-RUN_DEPENDS+= ${PREFIX}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
-. endif
+BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
+RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
+.endif
PLIST_SUB+= SUFFIX_MPI="_mpi" MPI=""
.else
PLIST_SUB+= SUFFIX_MPI="" MPI="@comment "
diff --git a/science/gromacs/files/patch-include__gmx_cyclecounter.h b/science/gromacs/files/patch-include__gmx_cyclecounter.h
new file mode 100644
index 000000000000..2af9cede4307
--- /dev/null
+++ b/science/gromacs/files/patch-include__gmx_cyclecounter.h
@@ -0,0 +1,11 @@
+--- ./include/gmx_cyclecounter.h.orig 2009-03-31 13:25:55.036329291 +0200
++++ ./include/gmx_cyclecounter.h 2009-03-31 13:26:11.504803886 +0200
+@@ -408,7 +408,7 @@
+ static __inline__ gmx_cycles_t gmx_cycles_read(void)
+ {
+ /* gcc inline assembly on sparc v9 */
+- ticks ret;
++ gmx_cycles_t ret;
+ __asm__("rd %%tick, %0" : "=r" (ret));
+ return ret;
+ }