aboutsummaryrefslogtreecommitdiffstats
path: root/science/lamprop
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-03-13 16:27:23 +0800
committeryuri <yuri@FreeBSD.org>2018-03-13 16:27:23 +0800
commit73fc93292828a1809e67d7af33faff06c55612d4 (patch)
tree4ee2523b99312546f64e73cd6f44524ed2aeb893 /science/lamprop
parent22b32e2799b50e79b9f97fbd089364e5606b4d2e (diff)
downloadfreebsd-ports-gnome-73fc93292828a1809e67d7af33faff06c55612d4.tar.gz
freebsd-ports-gnome-73fc93292828a1809e67d7af33faff06c55612d4.tar.zst
freebsd-ports-gnome-73fc93292828a1809e67d7af33faff06c55612d4.zip
science/lamprop: Unbreak by fixing the python interpreter in the shebang
While here, added NO_ARCH. Approved by: portmgr (port compliance, infrastructure)
Diffstat (limited to 'science/lamprop')
-rw-r--r--science/lamprop/Makefile2
-rw-r--r--science/lamprop/files/patch-build.py11
2 files changed, 12 insertions, 1 deletions
diff --git a/science/lamprop/Makefile b/science/lamprop/Makefile
index d954579af43d..133801c1ce38 100644
--- a/science/lamprop/Makefile
+++ b/science/lamprop/Makefile
@@ -14,9 +14,9 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= ${PYNUMPY}
USES= python:3.4+
-
USE_GITHUB= yes
GH_ACCOUNT= rsmith-nl
+NO_ARCH= yes
PLIST_FILES= bin/lamprop \
man/man1/lamprop.1.gz \
diff --git a/science/lamprop/files/patch-build.py b/science/lamprop/files/patch-build.py
new file mode 100644
index 000000000000..c28f7ccca128
--- /dev/null
+++ b/science/lamprop/files/patch-build.py
@@ -0,0 +1,11 @@
+--- build.py.orig 2018-03-13 08:20:32 UTC
++++ build.py
+@@ -28,7 +28,7 @@ def mkarchive(name, modules, main='__mai
+ """
+ std = '__main__.py'
+ vi = sys.version_info
+- shebang = '#!/usr/bin/env python{}\n'.format(vi.major).encode('ascii')
++ shebang = '#!/usr/bin/env python{}.{}\n'.format(vi.major, vi.minor).encode('ascii')
+ if isinstance(modules, str):
+ modules = [modules]
+ if main != std: