aboutsummaryrefslogtreecommitdiffstats
path: root/science/libctl/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2015-01-04 20:56:56 +0800
committerRene Ladan <rene@FreeBSD.org>2015-01-04 20:56:56 +0800
commitc818bdfc82a5b1426bf8ca9ec13c60e9f39ce014 (patch)
treeeee5533406efb52881fcbfd63e5910ffe1c2bfcb /science/libctl/Makefile
parentbb6bb7e7b7cbd35e448687663ac85f78afbba747 (diff)
downloadfreebsd-ports-gnome-c818bdfc82a5b1426bf8ca9ec13c60e9f39ce014.tar.gz
freebsd-ports-gnome-c818bdfc82a5b1426bf8ca9ec13c60e9f39ce014.tar.zst
freebsd-ports-gnome-c818bdfc82a5b1426bf8ca9ec13c60e9f39ce014.zip
science/libctl: update to 3.2.2
- use lang/guile2 instead of lang/guile - add pkgconfig to USES - add option to use lang/nlopt - strip libraries PR: 196175 Submitted by: Rainer Hurling Approved by: maintainer timeout (devel@stasyan.com, 14 days)
Diffstat (limited to 'science/libctl/Makefile')
-rw-r--r--science/libctl/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/science/libctl/Makefile b/science/libctl/Makefile
index 8265aa5c07d8..4ee7811b04d8 100644
--- a/science/libctl/Makefile
+++ b/science/libctl/Makefile
@@ -2,29 +2,37 @@
# $FreeBSD$
PORTNAME= libctl
-PORTVERSION= 3.2.1
-PORTREVISION= 5
+PORTVERSION= 3.2.2
CATEGORIES= science math
MASTER_SITES= http://ab-initio.mit.edu/libctl/
MAINTAINER= devel@stasyan.com
COMMENT= Control Language Library
-LIB_DEPENDS= libguile.so:${PORTSDIR}/lang/guile
+LICENSE= GPLv2
+
+LIB_DEPENDS= libguile-2.0.so:${PORTSDIR}/lang/guile2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
-USES= fortran libtool
+USES= fortran libtool pkgconfig
USE_LDCONFIG= yes
+LDFLAGS+= -L${LOCALBASE}/lib -lm
BROKEN_sparc64= does not build
-OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFINE= NLOPT DOCS EXAMPLES
+NLOPT_DESC= Use NLopt, an external NonLinear OPTimizer
+
+NLOPT_LIB_DEPENDS= libnlopt.so:${PORTSDIR}/math/nlopt
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${CP} -R ${WRKSRC}/doc/ ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/ ${STAGEDIR}${EXAMPLESDIR}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libctl.so.5.0.2
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libctlgeom.so.5.0.2
+ @${STRIP_CMD} ${STAGEDIR}${EXAMPLESDIR}/.libs/example
.include <bsd.port.mk>