aboutsummaryrefslogtreecommitdiffstats
path: root/science/mpb
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-12-28 05:28:47 +0800
committertijl <tijl@FreeBSD.org>2013-12-28 05:28:47 +0800
commit079fd030b0f3797f8e1c1063aecf5d048cfb8d46 (patch)
tree4838170b5cfee79a9123264c1e6bbf32b9d57658 /science/mpb
parent959dd4f51dddcf0ba40716e8df821fd207f28a42 (diff)
downloadfreebsd-ports-gnome-079fd030b0f3797f8e1c1063aecf5d048cfb8d46.tar.gz
freebsd-ports-gnome-079fd030b0f3797f8e1c1063aecf5d048cfb8d46.tar.zst
freebsd-ports-gnome-079fd030b0f3797f8e1c1063aecf5d048cfb8d46.zip
- New LIB_DEPENDS syntax.
- USES=fortran. - Replace WITH_ATLAS with ATLAS option. - Staging.
Diffstat (limited to 'science/mpb')
-rw-r--r--science/mpb/Makefile39
-rw-r--r--science/mpb/pkg-plist3
2 files changed, 23 insertions, 19 deletions
diff --git a/science/mpb/Makefile b/science/mpb/Makefile
index 79c91d13f0e2..2d1d38375820 100644
--- a/science/mpb/Makefile
+++ b/science/mpb/Makefile
@@ -12,38 +12,39 @@ COMMENT= MIT Photonic-Bands
LICENSE= GPLv2
-MAKE_JOBS_UNSAFE= yes
-
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS= fftw:${PORTSDIR}/math/fftw \
- hdf5:${PORTSDIR}/science/hdf5 \
- ctl:${PORTSDIR}/science/libctl \
- guile:${PORTSDIR}/lang/guile
+LIB_DEPENDS= libfftw.so:${PORTSDIR}/math/fftw \
+ libhdf5.so:${PORTSDIR}/science/hdf5 \
+ libctl.so:${PORTSDIR}/science/libctl \
+ libguile.so:${PORTSDIR}/lang/guile
-USE_FORTRAN= yes
+OPTIONS_DEFINE= ATLAS
+ATLAS_DESC= Use math/atlas instead of math/lapack
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+USES= fortran
GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
-WITH_ATLAS= yes
-.endif
-.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MATLAS}
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
CONFIGURE_ARGS+= --with-lapack=-lalapack
.else
-LIB_DEPENDS+= blas:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas \
+ liblapack.so:${PORTSDIR}/math/lapack
CONFIGURE_ARGS+= --with-lapack=-llapack
.endif
-MAN1= mpb.1 mpb-data.1 mpb-split.1
-
post-patch:
@${REINPLACE_CMD} -e 's|-lhdf5 |-lhdf5 ${PTHREAD_LIBS} |g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} \
+ -e '/INSTALL/s/$$(prefix)/$$(DESTDIR)$$(prefix)/' \
+ -e '/INSTALL/s/$$(mandir)/$$(DESTDIR)$$(mandir)/' \
+ ${WRKSRC}/mpb-ctl/Makefile.in ${WRKSRC}/utils/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/mpb/pkg-plist b/science/mpb/pkg-plist
index 6bb62c7e2c94..50722719fa4f 100644
--- a/science/mpb/pkg-plist
+++ b/science/mpb/pkg-plist
@@ -1,5 +1,8 @@
bin/mpb
bin/mpb-split
bin/mpb-data
+man/man1/mpb.1.gz
+man/man1/mpb-data.1.gz
+man/man1/mpb-split.1.gz
share/libctl/specs/mpb.scm
@dirrmtry share/libctl/specs