aboutsummaryrefslogtreecommitdiffstats
path: root/science/ncs
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-25 06:17:41 +0800
committermarino <marino@FreeBSD.org>2015-03-25 06:17:41 +0800
commitf74761b9bfd1bb59f543e04731e6db8a2aaf3824 (patch)
tree60ad4767380537b433ea1dfdfc2e72ae71751873 /science/ncs
parentde6c295f80cbf9bf9ee451a705b2e1d68ddfeca3 (diff)
downloadfreebsd-ports-gnome-f74761b9bfd1bb59f543e04731e6db8a2aaf3824.tar.gz
freebsd-ports-gnome-f74761b9bfd1bb59f543e04731e6db8a2aaf3824.tar.zst
freebsd-ports-gnome-f74761b9bfd1bb59f543e04731e6db8a2aaf3824.zip
3 ports categories: Remove $PTHREAD_LIBS
Categories: print, science, emulators approved by: PTHREAD blanket
Diffstat (limited to 'science/ncs')
-rw-r--r--science/ncs/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/science/ncs/Makefile b/science/ncs/Makefile
index 590b8938c114..6769c6b32254 100644
--- a/science/ncs/Makefile
+++ b/science/ncs/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ENV= MPI_LIBS="${MPI_LIBS}" \
PYEXE="${PYTHON_CMD}"
CONFIGURE_ARGS= --with-blas-libs="${BLASLIB} ${LAPACKLIB}"
MAKE_ENV= NOM_ARCH=${OPSYS} CS_MPI_PATH=${MPI_HOME}/bin \
- PTHREAD_LIBS=${PTHREAD_LIBS} TERM=${TERM} \
+ PTHREAD_LIBS=-lpthread TERM=${TERM} \
MPI_HOME=${MPI_HOME} MPI_LIBS="${MPI_LIBS}"
USE_LDCONFIG= yes
@@ -88,7 +88,7 @@ MPI_LIBS= -lmpi -lorte -lopal
MPI_HOME= ${LOCALBASE}
BUILD_DEPENDS+= ${MPI_HOME}/bin/mpicc:${PORTSDIR}/net/mpich2
RUN_DEPENDS+= ${MPI_HOME}/bin/mpirun:${PORTSDIR}/net/mpich2
-MPI_LIBS= -lmpich -lmpl ${PTHREAD_LIBS}
+MPI_LIBS= -lmpich -lmpl -lpthread
.endif
.if ${PORT_OPTIONS:MDOCS}