aboutsummaryrefslogtreecommitdiffstats
path: root/science/openbabel/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-10-18 02:49:09 +0800
committermakc <makc@FreeBSD.org>2013-10-18 02:49:09 +0800
commit826e0cae8162ab4c57ca167da43a7c9b3b2a4533 (patch)
tree5b541303041df5ad7140d6154ca615ab6c664267 /science/openbabel/Makefile
parent8431f6a9ffe5e4652befd33ed931adae8dbd2287 (diff)
downloadfreebsd-ports-gnome-826e0cae8162ab4c57ca167da43a7c9b3b2a4533.tar.gz
freebsd-ports-gnome-826e0cae8162ab4c57ca167da43a7c9b3b2a4533.tar.zst
freebsd-ports-gnome-826e0cae8162ab4c57ca167da43a7c9b3b2a4533.zip
- Add dependency on pkgconfig when building with cairo support [1]
- Support staging - Use option helpers Reported by: Andreas Nilsson via mail [1]
Diffstat (limited to 'science/openbabel/Makefile')
-rw-r--r--science/openbabel/Makefile32
1 files changed, 4 insertions, 28 deletions
diff --git a/science/openbabel/Makefile b/science/openbabel/Makefile
index b888168a6f63..05b9f18557e4 100644
--- a/science/openbabel/Makefile
+++ b/science/openbabel/Makefile
@@ -18,45 +18,21 @@ USES= cmake:outsource
CMAKE_ARGS= -DBUILD_GUI=off
USE_LDCONFIG= yes
-MAN1= babel.1 \
- obabel.1 \
- obchiral.1 \
- obconformer.1 \
- obenergy.1 \
- obfit.1 \
- obgen.1 \
- obgrep.1 \
- obgui.1 \
- obminimize.1 \
- obprobe.1 \
- obprop.1 \
- obrotamer.1 \
- obrotate.1 \
- obspectrophore.1 \
- roundtrip.1
-
PLIST_SUB= VERSION="${PORTVERSION}"
OPTIONS_DEFINE= CAIRO PYTHON
OPTIONS_DEFAULT= PYTHON
+OPTIONS_SUB= yes
+
CAIRO_DESC= PNG support via cairo library
+CAIRO_LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo
+CAIRO_USES= pkgconfig
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MCAIRO}
-LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo
-PLIST_SUB+= CAIRO=""
-.else
-PLIST_SUB+= CAIRO="@comment "
-.endif
-
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
CMAKE_ARGS+= -DPYTHON_BINDINGS=on
-PLIST_SUB+= PYTHON=""
-.else
-PLIST_SUB+= PYTHON="@comment "
.endif
post-patch: