aboutsummaryrefslogtreecommitdiffstats
path: root/science/openbabel
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-11 15:50:24 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-11 15:50:24 +0800
commit3204737e4f2f58befbe765886631db2ebe6c7d6a (patch)
treed598c4041aac9b35caef90ac1f259293ff4fbc88 /science/openbabel
parentdf1cfe66a63e00ef2fe216400dc78f5bb5fb834b (diff)
downloadfreebsd-ports-gnome-3204737e4f2f58befbe765886631db2ebe6c7d6a.tar.gz
freebsd-ports-gnome-3204737e4f2f58befbe765886631db2ebe6c7d6a.tar.zst
freebsd-ports-gnome-3204737e4f2f58befbe765886631db2ebe6c7d6a.zip
science/openbabel: fix build with GCC-based architectures
While here, also add USES=gnome. PR: 233912 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Diffstat (limited to 'science/openbabel')
-rw-r--r--science/openbabel/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/science/openbabel/Makefile b/science/openbabel/Makefile
index 9933f74c4aed..892cc7021152 100644
--- a/science/openbabel/Makefile
+++ b/science/openbabel/Makefile
@@ -13,11 +13,9 @@ COMMENT= Chemical toolbox designed to speak the many languages of chemical data
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= Does not build: relocation truncated to fit: R_PPC64_TOC16_DS
-
CONFLICTS_INSTALL= babel-*
-USES= cmake:outsource eigen:3
+USES= compiler:c++11-lang cmake:outsource eigen:3 gnome
USE_CXXSTD= gnu++98
USE_GNOME= libxml2
USE_LDCONFIG= yes
@@ -37,7 +35,12 @@ PYTHON_CMAKE_BOOL= PYTHON_BINDINGS
GUI_CMAKE_BOOL= BUILD_GUI
GUI_CMAKE_ON= -DwxWidgets_CONFIG_EXECUTABLE:STRING=${WX_CONFIG}
-GUI_USE= WX=3.0
+GUI_USE= WX=3.1
+
+.if exists(/usr/lib/libstdc++.so)
+CXXFLAGS+= -Wno-narrowing
+USE_CXXSTD= c++11
+.endif
post-patch:
${REINPLACE_CMD} -e '/pkgconfig/s,$${LIB_INSTALL_DIR},libdata,' \