aboutsummaryrefslogtreecommitdiffstats
path: root/science/psi3
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-11-23 10:16:19 +0800
committermaho <maho@FreeBSD.org>2004-11-23 10:16:19 +0800
commit14b9c1c29f05afe83b7b130d75b659aea890c18f (patch)
tree870530a7a34f9668cb6e2a722ce0f9ac820a3291 /science/psi3
parent4293e529c636bf29e8e11b9be5dd8ef066c20528 (diff)
downloadfreebsd-ports-gnome-14b9c1c29f05afe83b7b130d75b659aea890c18f.tar.gz
freebsd-ports-gnome-14b9c1c29f05afe83b7b130d75b659aea890c18f.tar.zst
freebsd-ports-gnome-14b9c1c29f05afe83b7b130d75b659aea890c18f.zip
Fix build with WITH_OPTIMIZED_FLAGS defined
PR: 74013 Submitted by: Jie Gao <gaoj at cpsc.ucalgary.ca>
Diffstat (limited to 'science/psi3')
-rw-r--r--science/psi3/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/science/psi3/Makefile b/science/psi3/Makefile
index 8543d34d8962..782ffe00ee31 100644
--- a/science/psi3/Makefile
+++ b/science/psi3/Makefile
@@ -39,6 +39,8 @@ CONFIGURE_ARGS= --with-cc=${CC} \
--with-libdirs="-L${LOCALBASE}/lib" \
--with-libs="-lcompat"
+.include <bsd.port.pre.mk>
+
.if defined(WITH_OPTIMIZED_FLAGS)
FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
@@ -85,4 +87,4 @@ do-install:
@${MKDIR} ${PREFIX}/share/examples/psi3
@${TAR} cf - -C ${WRKSRC}/tests . | ${TAR} xf - -C ${PREFIX}/share/examples/psi3
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>