aboutsummaryrefslogtreecommitdiffstats
path: root/science/py-h5py/files
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-18 13:06:18 +0800
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-18 13:44:04 +0800
commitc3183a0a8bacf27f8ae6fe0801965cdf355d3aa0 (patch)
tree7d1d9b516df6893da3b4dfa7b09bfa79f66affde /science/py-h5py/files
parent2ff060b9063b92ed4e2673f8f772966624bff476 (diff)
downloadfreebsd-ports-gnome-c3183a0a8bacf27f8ae6fe0801965cdf355d3aa0.tar.gz
freebsd-ports-gnome-c3183a0a8bacf27f8ae6fe0801965cdf355d3aa0.tar.zst
freebsd-ports-gnome-c3183a0a8bacf27f8ae6fe0801965cdf355d3aa0.zip
science/py-h5py: Update to 3.2.1
- Update USES=python of dependent ports Changes: https://github.com/h5py/h5py/releases https://github.com/h5py/h5py/blob/master/docs/whatsnew/3.2.rst
Diffstat (limited to 'science/py-h5py/files')
-rw-r--r--science/py-h5py/files/patch-setup.py13
1 files changed, 6 insertions, 7 deletions
diff --git a/science/py-h5py/files/patch-setup.py b/science/py-h5py/files/patch-setup.py
index 3a3544a35b81..e6b3709d1b00 100644
--- a/science/py-h5py/files/patch-setup.py
+++ b/science/py-h5py/files/patch-setup.py
@@ -1,20 +1,19 @@
---- setup.py.orig 2020-11-06 14:25:11 UTC
+--- setup.py.orig 2021-03-05 10:02:07 UTC
+++ setup.py
-@@ -27,10 +27,7 @@ VERSION = '3.1.0'
+@@ -27,9 +27,7 @@ VERSION = '3.2.1'
# Minimum supported versions of Numpy & Cython depend on the Python version
NUMPY_MIN_VERSIONS = [
# Numpy Python
-- ('1.12', "=='3.6'"),
- ('1.14.5', "=='3.7'"),
- ('1.17.5', "=='3.8'"),
- ('1.19.3', ">='3.9'"),
-+ ('1.14.5', ">='3.6'"),
++ ('1.14.5', ">='3.7'"),
]
# these are required to use h5py
-@@ -49,7 +46,7 @@ SETUP_REQUIRES = [
- f"Cython >=0.29; python_version<'3.8'",
- f"Cython >=0.29.14; python_version>='3.8'",
+@@ -49,7 +47,7 @@ SETUP_REQUIRES = [
+ "Cython >=0.29.14; python_version=='3.8'",
+ "Cython >=0.29.15; python_version>='3.9'",
] + [
- f"numpy =={np_min}; python_version{py_condition}"
+ f"numpy >={np_min}; python_version{py_condition}"