aboutsummaryrefslogtreecommitdiffstats
path: root/science/py-kliff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-05-04 04:58:00 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2020-05-04 04:58:00 +0800
commita20df57f875114ef255f28c08be99af8f0dd908c (patch)
tree2e7ecc4d899d8872a535c1bc9a18614cb32e1e9f /science/py-kliff
parent053b0a869ea0a7b313a771e5afb1fd13ee2340b0 (diff)
downloadfreebsd-ports-gnome-a20df57f875114ef255f28c08be99af8f0dd908c.tar.gz
freebsd-ports-gnome-a20df57f875114ef255f28c08be99af8f0dd908c.tar.zst
freebsd-ports-gnome-a20df57f875114ef255f28c08be99af8f0dd908c.zip
New port: science/py-kliff: KIM-based Learning-Integrated Fitting Framework
Diffstat (limited to 'science/py-kliff')
-rw-r--r--science/py-kliff/Makefile25
-rw-r--r--science/py-kliff/distinfo3
-rw-r--r--science/py-kliff/pkg-descr5
3 files changed, 33 insertions, 0 deletions
diff --git a/science/py-kliff/Makefile b/science/py-kliff/Makefile
new file mode 100644
index 000000000000..9a2a18fb1b89
--- /dev/null
+++ b/science/py-kliff/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= kliff
+DISTVERSION= 0.1.6
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= KIM-based Learning-Integrated Fitting Framework
+
+LICENSE= CDDL
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
+
+USES= compiler:c++11-lang python
+USE_PYTHON= distutils autoplist
+
+post-install:
+ @${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} -name "*.so" | ${XARGS} ${STRIP_CMD}
+
+.include <bsd.port.mk>
diff --git a/science/py-kliff/distinfo b/science/py-kliff/distinfo
new file mode 100644
index 000000000000..16611f3dbd1d
--- /dev/null
+++ b/science/py-kliff/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1588538293
+SHA256 (kliff-0.1.6.tar.gz) = ed03c33203be97695e8ac80051b300476c0ed8f0774770570901bde82462072a
+SIZE (kliff-0.1.6.tar.gz) = 1940411
diff --git a/science/py-kliff/pkg-descr b/science/py-kliff/pkg-descr
new file mode 100644
index 000000000000..1c68e08db4c1
--- /dev/null
+++ b/science/py-kliff/pkg-descr
@@ -0,0 +1,5 @@
+KLIFF is an interatomic potential fitting package that can be used to fit
+physics-motivated (PM) potentials, as well as machine learning potentials such
+as the neural network (NN) models.
+
+WWW: https://github.com/mjwen/kliff