aboutsummaryrefslogtreecommitdiffstats
path: root/science/py-mlpy/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-24 01:02:20 +0800
committermiwi <miwi@FreeBSD.org>2009-04-24 01:02:20 +0800
commit99cecdd29130714ac760347756d1e615d404279d (patch)
treec3c48d35e02bb4e0123e97849aa508a3616d94f4 /science/py-mlpy/Makefile
parent9566791e8eb91958788d9974cc2fc901e642ecb5 (diff)
downloadfreebsd-ports-gnome-99cecdd29130714ac760347756d1e615d404279d.tar.gz
freebsd-ports-gnome-99cecdd29130714ac760347756d1e615d404279d.tar.zst
freebsd-ports-gnome-99cecdd29130714ac760347756d1e615d404279d.zip
Machine Learning PY (mlpy) is a high-performance Python package for
predictive modeling. It makes extensive use of numpy (http://scipy.org) to provide fast N-dimensional array manipulation and easy integration of C code. mlpy provides high level procedures that support, with few lines of code, the design of rich Data Analysis Protocols (DAPs) for preprocessing, clustering, predictive classification and feature selection. Methods are available for feature weighting and ranking, data resampling, error evaluation and experiment landscaping.The package includes tools to measure stability in sets of ranked feature lists. WWW: http://mlpy.fbk.eu/ PR: ports/133932 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'science/py-mlpy/Makefile')
-rw-r--r--science/py-mlpy/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/science/py-mlpy/Makefile b/science/py-mlpy/Makefile
new file mode 100644
index 000000000000..0769e7e13f53
--- /dev/null
+++ b/science/py-mlpy/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-mlpy
+# Date created: 18 April, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mlpy
+PORTVERSION= 2.0.0
+CATEGORIES= science python
+MASTER_SITES= https://mlpy.fbk.eu/download/src/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= MLPY-${PORTVERSION}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= High performance Python package for predictive modeling
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= MLPY
+
+.include <bsd.port.mk>