aboutsummaryrefslogtreecommitdiffstats
path: root/science/py-netCDF4
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-02-24 04:18:45 +0800
committermiwi <miwi@FreeBSD.org>2009-02-24 04:18:45 +0800
commitd5ddc03909374401abd0faf52e958738bd28bfdc (patch)
treeed963ba425577e1c76bde30885a47ebdc7f860f6 /science/py-netCDF4
parent1d28b2263470a90abd9560f3190fda88e36984d8 (diff)
downloadfreebsd-ports-gnome-d5ddc03909374401abd0faf52e958738bd28bfdc.tar.gz
freebsd-ports-gnome-d5ddc03909374401abd0faf52e958738bd28bfdc.tar.zst
freebsd-ports-gnome-d5ddc03909374401abd0faf52e958738bd28bfdc.zip
netCDF version 4 has many features not found in earlier versions of the
library and is implemented on top of HDF5. This module can read and write files in both the new netCDF 4 and the old netCDF 3 format, and can create files that are readable by HDF5 clients. The API modelled after Scientific.IO.NetCDF, and should be familiar to users of that module. Many new features of netCDF 4 are implemented, such as multiple unlimited dimensions, groups and zlib data compression. All the new primitive data types (such as 64 bit and unsigned integer types) are implemented, except variable-length strings (NC_STRING). User defined data types (compound, vlen, enum etc.) are not supported. WWW: http://code.google.com/p/netcdf4-python/ PR: ports/131866 Submitted by: wenheping at gmail.com
Diffstat (limited to 'science/py-netCDF4')
-rw-r--r--science/py-netCDF4/Makefile25
-rw-r--r--science/py-netCDF4/distinfo3
-rw-r--r--science/py-netCDF4/pkg-descr14
-rw-r--r--science/py-netCDF4/pkg-plist13
4 files changed, 55 insertions, 0 deletions
diff --git a/science/py-netCDF4/Makefile b/science/py-netCDF4/Makefile
new file mode 100644
index 000000000000..8740f2e1df34
--- /dev/null
+++ b/science/py-netCDF4/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: netCDF4
+# Date created: 18 Feb, 2009
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= netCDF4
+PORTVERSION= 0.7.7
+CATEGORIES= science python
+MASTER_SITES= http://netcdf4-python.googlecode.com/files/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Python Interface to the NetCDF Library(versions 3 and 4)
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= hdf5.6:${PORTSDIR}/science/hdf5-18 \
+ netcdf.5:${PORTSDIR}/science/netcdf4
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-netCDF4/distinfo b/science/py-netCDF4/distinfo
new file mode 100644
index 000000000000..f3687848f99e
--- /dev/null
+++ b/science/py-netCDF4/distinfo
@@ -0,0 +1,3 @@
+MD5 (netCDF4-0.7.7.tar.gz) = 0532342106f6f2bde28dd09dbf6b388c
+SHA256 (netCDF4-0.7.7.tar.gz) = 4bcb9ac71488bdc121e6701f13fb7a9ef2e35f97f13b476e6eb8366f984af5d2
+SIZE (netCDF4-0.7.7.tar.gz) = 416486
diff --git a/science/py-netCDF4/pkg-descr b/science/py-netCDF4/pkg-descr
new file mode 100644
index 000000000000..7aaa2bf9b6b0
--- /dev/null
+++ b/science/py-netCDF4/pkg-descr
@@ -0,0 +1,14 @@
+netCDF version 4 has many features not found in earlier versions of the
+library and is implemented on top of HDF5. This module can read and
+write files in both the new netCDF 4 and the old netCDF 3 format, and
+can create files that are readable by HDF5 clients. The API modelled
+after Scientific.IO.NetCDF, and should be familiar to users of that
+module.
+
+Many new features of netCDF 4 are implemented, such as multiple
+unlimited dimensions, groups and zlib data compression. All the new
+primitive data types (such as 64 bit and unsigned integer types) are
+implemented, except variable-length strings (NC_STRING). User defined
+data types (compound, vlen, enum etc.) are not supported.
+
+WWW: http://code.google.com/p/netcdf4-python/
diff --git a/science/py-netCDF4/pkg-plist b/science/py-netCDF4/pkg-plist
new file mode 100644
index 000000000000..9e8ac89c982c
--- /dev/null
+++ b/science/py-netCDF4/pkg-plist
@@ -0,0 +1,13 @@
+bin/grib2nc4
+bin/nc3tonc4
+%%PYTHON_SITELIBDIR%%/netCDF4_utils.py
+%%PYTHON_SITELIBDIR%%/netCDF4_utils.pyc
+%%PYTHON_SITELIBDIR%%/netCDF4_utils.pyo
+%%PYTHON_SITELIBDIR%%/netCDF4.so
+%%PYTHON_SITELIBDIR%%/netcdftime/__init__.py
+%%PYTHON_SITELIBDIR%%/netcdftime/__init__.pyc
+%%PYTHON_SITELIBDIR%%/netcdftime/__init__.pyo
+%%PYTHON_SITELIBDIR%%/netcdftime/netcdftime.py
+%%PYTHON_SITELIBDIR%%/netcdftime/netcdftime.pyc
+%%PYTHON_SITELIBDIR%%/netcdftime/netcdftime.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/netcdftime